summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-19 15:27:52 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-19 15:27:52 +0000
commit48376358feda4c9f473093186b98ac126bcbf5b9 (patch)
tree2b5b11152f5fa8cbd032b1a8cda2b6984b0a0e10 /dev-python/websocket-client/websocket-client-0.21.0.ebuild
parentStable on arm, ppc and ppc64. Bug #524670 (diff)
downloadhistorical-48376358feda4c9f473093186b98ac126bcbf5b9.tar.gz
historical-48376358feda4c9f473093186b98ac126bcbf5b9.tar.bz2
historical-48376358feda4c9f473093186b98ac126bcbf5b9.zip
add version 0.21.0
Package-Manager: portage-2.2.14_rc1/cvs/Linux x86_64 Manifest-Sign-Key: 0x11A8217C!
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.21.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.21.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.21.0.ebuild b/dev-python/websocket-client/websocket-client-0.21.0.ebuild
new file mode 100644
index 000000000000..aeb1400d8562
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.21.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/websocket-client-0.21.0.ebuild,v 1.1 2014/10/19 15:27:45 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="WebSocket client for python. hybi13 is supported"
+HOMEPAGE="https://github.com/liris/websocket-client"
+SRC_URI="https://github.com/liris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2*' )
+"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}