summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-19 17:43:14 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-19 17:43:14 +0000
commitce038f66302c731f09f44a02c9db757a4d0715b4 (patch)
tree1a881559ec5de7fb91aaf00430e32f2a1a5a2fa0 /dev-python/wehjit/wehjit-0.2.2-r1.ebuild
parentAlways ensure the check-report is generated. fixes bug #462010 (diff)
downloadhistorical-ce038f66302c731f09f44a02c9db757a4d0715b4.tar.gz
historical-ce038f66302c731f09f44a02c9db757a4d0715b4.tar.bz2
historical-ce038f66302c731f09f44a02c9db757a4d0715b4.zip
migration revbump
Package-Manager: portage-2.1.11.40/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/wehjit/wehjit-0.2.2-r1.ebuild')
-rw-r--r--dev-python/wehjit/wehjit-0.2.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wehjit/wehjit-0.2.2-r1.ebuild b/dev-python/wehjit/wehjit-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..884008b749a6
--- /dev/null
+++ b/dev-python/wehjit/wehjit-0.2.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/wehjit-0.2.2-r1.ebuild,v 1.1 2013/03/19 17:42:51 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python web-widget library"
+HOMEPAGE="http://jderose.fedorapeople.org/wehjit"
+SRC_URI="http://jderose.fedorapeople.org/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/genshi
+ dev-python/assets[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( README NEWS )
+
+PATCHES=( "${FILESDIR}"/${P}-SkipTest.patch )
+
+python_test() {
+ if [[ "${EPYTHON:6:3}" == '2.6' ]]; then
+ nosetests -I test_app* -e=*getitem
+ else
+ nosetests
+ fi
+}