summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-13 07:29:25 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-13 07:29:25 +0000
commit712565a77c54a8cbe3ffa7a5f31b433761588d55 (patch)
tree32642aca53e77980db27ec90bc5795bccfbbdc12 /dev-python
parentpatch for pam_mysql to link against pam (diff)
downloadhistorical-712565a77c54a8cbe3ffa7a5f31b433761588d55.tar.gz
historical-712565a77c54a8cbe3ffa7a5f31b433761588d55.tar.bz2
historical-712565a77c54a8cbe3ffa7a5f31b433761588d55.zip
Version bump webpy to 0.36.
Package-Manager: portage-2.1.10.15/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webpy/ChangeLog9
-rw-r--r--dev-python/webpy/Manifest14
-rw-r--r--dev-python/webpy/webpy-0.36.ebuild41
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/webpy/ChangeLog b/dev-python/webpy/ChangeLog
index e9994c29f8e2..e5f5bacd0ba2 100644
--- a/dev-python/webpy/ChangeLog
+++ b/dev-python/webpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webpy
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.19 2010/08/02 14:59:29 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.20 2011/09/13 07:29:25 djc Exp $
+
+*webpy-0.36 (13 Sep 2011)
+
+ 13 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +webpy-0.36.ebuild:
+ Version bump to 0.36.
02 Aug 2010; Jeroen Roovers <jer@gentoo.org> webpy-0.34.ebuild:
Stable for HPPA too.
diff --git a/dev-python/webpy/Manifest b/dev-python/webpy/Manifest
index f85eb2cd369a..b4ca32ed8cdb 100644
--- a/dev-python/webpy/Manifest
+++ b/dev-python/webpy/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
DIST web.py-0.34.tar.gz 79925 RMD160 84e9247c361dfd0e0d40c68c65f09fc712169ee1 SHA1 bd8ef2acd643702279348e57f6ac8dd1750f72f5 SHA256 53d350c83fec92f2638326bb5f97daace753c4f1e7cc2b007d8866469c11995e
+DIST web.py-0.36.tar.gz 87951 RMD160 0d8fb464fe47e705d65c485ff135840649dd19f2 SHA1 15492e921dd5ee8ec6044c912e02561f7aa4d283 SHA256 c45ec5b5feaaba53bbae69dd971c281832f1332d5949cd6e5ca27747fe92256a
EBUILD webpy-0.34.ebuild 968 RMD160 2316df5b52ec33e986dc55aa541a94f6bf25b636 SHA1 efd31bbf33e50199e766e4e386d763d866047698 SHA256 13227c7e219d1688923f77d0da600f76c9da345f243d14128f5007270f6fc226
-MISC ChangeLog 2379 RMD160 cf11b4ebcd7292d4f05898fadecfcff8585e7eb5 SHA1 77df0a74ab4c73be11f7f226c6a6113b94ede8bb SHA256 66b18ac73f7c88e440a4018d1880a2d54f8644a999a50c480efb2496bbc14653
+EBUILD webpy-0.36.ebuild 971 RMD160 05b34e1a18801b28cf4a1203c52af38f7ba1ca5f SHA1 412d4da3e5a5f6ec717982fee2d02848a518acd4 SHA256 d302890d7927325e2d759a2c76e880265046582d2a0925da5fc5c9f22ebcc5e8
+MISC ChangeLog 2499 RMD160 88a8527ca62b1e53328b0e798a9781b679a9c533 SHA1 d90e9fd020c02a94623079ee705ee844f5976ba8 SHA256 f8613eaf264e0c47acded4d9c742213d6566ff0ae03030e4cc1c664755ae65b1
MISC metadata.xml 324 RMD160 ef213d56e374aec414651133965fd37e5a57e2f6 SHA1 34018f1ff17c5d6c0129e75db713eb2b55370f2c SHA256 7ec3ce4112364dcb56aebca43eee836a162b39b8faef16c6a1c37719e556c00d
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEAREKAAYFAk5vBmAACgkQxeMuLWsGW/vazACeLsUlg8aRG2ARErrxyj3sAPtt
+UlAAoKX5rhFI7Cc+kxRAHh6NFNDiiNAr
+=NSxv
+-----END PGP SIGNATURE-----
diff --git a/dev-python/webpy/webpy-0.36.ebuild b/dev-python/webpy/webpy-0.36.ebuild
new file mode 100644
index 000000000000..99ed02170538
--- /dev/null
+++ b/dev-python/webpy/webpy-0.36.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.36.ebuild,v 1.1 2011/09/13 07:29:25 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for Python"
+HOMEPAGE="http://www.webpy.org http://pypi.python.org/pypi/web.py"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/web.py-${PV}"
+
+PYTHON_MODNAME="web"
+
+src_test() {
+ testing() {
+ local return_status="0" test tests="db http net template utils"
+ for test in ${tests}; do
+ echo "Running doctests in ${test}.py..."
+ "$(PYTHON)" web/${test}.py || return_status="$?"
+ done
+
+ return "${return_status}"
+ }
+ python_execute_function testing
+}