summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-10-15 10:24:17 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-10-15 10:24:17 +0000
commit8233b5bf1e4c91535d68a3ebe247b0e0d5792183 (patch)
tree121b816f767e2d49ae3dcd38fd8c80e5868e8eab /dev-python
parentAdd a fedora-dev mirror class, for development RPMs. They're only on ~10% of ... (diff)
downloadhistorical-8233b5bf1e4c91535d68a3ebe247b0e0d5792183.tar.gz
historical-8233b5bf1e4c91535d68a3ebe247b0e0d5792183.tar.bz2
historical-8233b5bf1e4c91535d68a3ebe247b0e0d5792183.zip
(#186802) Updates so the files are on mirrors. Also switch to using fedora-dev thirdpartymirrors setting to better find RPMs.
Package-Manager: portage-2.1.3.13
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyxf86config/ChangeLog9
-rw-r--r--dev-python/pyxf86config/files/digest-pyxf86config-0.3.343
-rw-r--r--dev-python/pyxf86config/pyxf86config-0.3.34.ebuild35
-rw-r--r--dev-python/rhpl/ChangeLog8
-rw-r--r--dev-python/rhpl/files/digest-rhpl-0.2103
-rw-r--r--dev-python/rhpl/rhpl-0.210.ebuild49
6 files changed, 105 insertions, 2 deletions
diff --git a/dev-python/pyxf86config/ChangeLog b/dev-python/pyxf86config/ChangeLog
index 1d7635072ba1..3ed9948e35f3 100644
--- a/dev-python/pyxf86config/ChangeLog
+++ b/dev-python/pyxf86config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyxf86config
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxf86config/ChangeLog,v 1.4 2007/10/15 09:44:59 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxf86config/ChangeLog,v 1.5 2007/10/15 10:23:41 dberkholz Exp $
+
+*pyxf86config-0.3.34 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +pyxf86config-0.3.34.ebuild:
+ (#186802) Updates so the files are on mirrors. Also switch to using
+ fedora-dev thirdpartymirrors setting to better find RPMs.
15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
pyxf86config-0.3.30.ebuild, pyxf86config-0.3.33.ebuild:
diff --git a/dev-python/pyxf86config/files/digest-pyxf86config-0.3.34 b/dev-python/pyxf86config/files/digest-pyxf86config-0.3.34
new file mode 100644
index 000000000000..96164bf4e02b
--- /dev/null
+++ b/dev-python/pyxf86config/files/digest-pyxf86config-0.3.34
@@ -0,0 +1,3 @@
+MD5 1b5de8519adac080bdc8705924ce26cf pyxf86config-0.3.34-1.fc8.src.rpm 252972
+RMD160 57c0d00e4f4e81f49a5ecd6e56dbb308f0d9c3bc pyxf86config-0.3.34-1.fc8.src.rpm 252972
+SHA256 ea9486bde7f80ba427964d70fda7c2497a60463068e8d403177a68385b69481b pyxf86config-0.3.34-1.fc8.src.rpm 252972
diff --git a/dev-python/pyxf86config/pyxf86config-0.3.34.ebuild b/dev-python/pyxf86config/pyxf86config-0.3.34.ebuild
new file mode 100644
index 000000000000..97bce4b4ce56
--- /dev/null
+++ b/dev-python/pyxf86config/pyxf86config-0.3.34.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxf86config/pyxf86config-0.3.34.ebuild,v 1.1 2007/10/15 10:23:41 dberkholz Exp $
+
+inherit python rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="8"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Python wrappers for libxf86config"
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/"
+SRC_URI="mirror://fedora-dev/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="=dev-libs/glib-2*
+ dev-lang/python"
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-server-1.1.1-r1"
+
+src_compile() {
+ python_version
+ econf \
+ --with-python-version=${PYVER} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-python/rhpl/ChangeLog b/dev-python/rhpl/ChangeLog
index da7bcc2b9ace..5b13c9e172f1 100644
--- a/dev-python/rhpl/ChangeLog
+++ b/dev-python/rhpl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rhpl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/ChangeLog,v 1.3 2007/10/15 09:45:34 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/ChangeLog,v 1.4 2007/10/15 10:24:17 dberkholz Exp $
+
+*rhpl-0.210 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; +rhpl-0.210.ebuild:
+ (#186802) Updates so the files are on mirrors. Also switch to using
+ fedora-dev thirdpartymirrors setting to better find RPMs.
15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; rhpl-0.188.ebuild,
rhpl-0.208.ebuild:
diff --git a/dev-python/rhpl/files/digest-rhpl-0.210 b/dev-python/rhpl/files/digest-rhpl-0.210
new file mode 100644
index 000000000000..3a922605e226
--- /dev/null
+++ b/dev-python/rhpl/files/digest-rhpl-0.210
@@ -0,0 +1,3 @@
+MD5 35c86c8980ef6f9b45cfed9f4e571595 rhpl-0.210-1.src.rpm 304781
+RMD160 9b1bf4d72a355b7c07491055a3518f4d3290b6ee rhpl-0.210-1.src.rpm 304781
+SHA256 d22838a4b7d07ed3a504c600a9bb95df14405085d77df694f1833c8aa57f8ece rhpl-0.210-1.src.rpm 304781
diff --git a/dev-python/rhpl/rhpl-0.210.ebuild b/dev-python/rhpl/rhpl-0.210.ebuild
new file mode 100644
index 000000000000..97d4fcd9c3c3
--- /dev/null
+++ b/dev-python/rhpl/rhpl-0.210.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/rhpl-0.210.ebuild,v 1.1 2007/10/15 10:24:17 dberkholz Exp $
+
+inherit eutils multilib python rpm toolchain-funcs
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Library of python code used by Red Hat Linux programs"
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/"
+SRC_URI="mirror://fedora-dev/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-lang/python
+ !<sys-libs/libkudzu-1.2"
+DEPEND="${RDEPEND}
+ !s390? ( >=net-wireless/wireless-tools-28 )
+ sys-devel/gettext"
+
+src_unpack() {
+ rpm_src_unpack
+# epatch "${FILESDIR}"/${PV}-use-raw-strings-for-gettext.diff
+
+ sed -i \
+ -e 's:gcc:$(CC):g' \
+ "${S}"/src/Makefile
+}
+
+src_compile() {
+ python_version
+ emake \
+ PYTHON=python${PYVER} \
+ LIBDIR=$(get_libdir) \
+ ARCH=${ARCH} \
+ CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON=python${PYVER} \
+ LIBDIR=$(get_libdir) \
+ install || die "emake install failed"
+}