summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-06 15:02:56 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-06 15:02:56 +0000
commita9b6d833c893b4b00f71c455f1b84ef0ebe9cddd (patch)
treed774af540a77e56cda4eb1c980e7d5f016d075b8 /dev-python
parentFixing bug #6769 (diff)
downloadhistorical-a9b6d833c893b4b00f71c455f1b84ef0ebe9cddd.tar.gz
historical-a9b6d833c893b4b00f71c455f1b84ef0ebe9cddd.tar.bz2
historical-a9b6d833c893b4b00f71c455f1b84ef0ebe9cddd.zip
Removed RDEPEND="${DEPEND}"
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mod_python/mod_python-2.7.8.ebuild7
-rw-r--r--dev-python/pmw/pmw-1.1.ebuild74
2 files changed, 35 insertions, 46 deletions
diff --git a/dev-python/mod_python/mod_python-2.7.8.ebuild b/dev-python/mod_python/mod_python-2.7.8.ebuild
index 1a50a8de49e5..884041a504a6 100644
--- a/dev-python/mod_python/mod_python-2.7.8.ebuild
+++ b/dev-python/mod_python/mod_python-2.7.8.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.8.ebuild,v 1.1 2002/10/21 12:43:23 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.8.ebuild,v 1.2 2002/11/06 15:02:56 vapier Exp $
DESCRIPTION="Python module for Apache"
SRC_URI="http://www.modpython.org/dist/${P}.tgz"
HOMEPAGE="http://www.modpython.org/"
+
LICENSE="AS-IS"
KEYWORDS="~x86"
SLOT="0"
DEPEND=">=net-www/apache-1.3.26-r2
dev-lang/python"
-RDEPEND="${DEPEND}"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -47,7 +46,6 @@ src_compile() {
emake || die "emake failed"
}
-
src_install() {
mkdir -p ${D}/usr/lib/apache-extramodules
mkdir ${D}/usr/lib/python2.2
@@ -79,7 +77,6 @@ pkg_postinst() {
einfo
}
-
pkg_config() {
${ROOT}/usr/sbin/apacheaddmod \
${ROOT}/etc/apache/conf/apache.conf \
diff --git a/dev-python/pmw/pmw-1.1.ebuild b/dev-python/pmw/pmw-1.1.ebuild
index 3cbbea73b08c..17b738029fac 100644
--- a/dev-python/pmw/pmw-1.1.ebuild
+++ b/dev-python/pmw/pmw-1.1.ebuild
@@ -1,55 +1,47 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.1.ebuild,v 1.1 2002/10/24 22:02:22 agenkin Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.1.ebuild,v 1.2 2002/11/06 15:02:22 vapier Exp $
DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
HOMEPAGE="http://pmw.sourceforge.net/"
-
-DEPEND=">=dev-lang/python-2.1"
-RDEPEND="${DEPEND}"
+SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="MIT"
-
-SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
-S="${WORKDIR}"/Pmw
+DEPEND=">=dev-lang/python-2.1"
+S="${WORKDIR}/Pmw"
src_compile() {
- if ! python -c "import Tkinter" >/dev/null 2>&1
- then
- die "You need to recompile Python with Tkinter support"
- fi
- python -c 'import compileall; compileall.compile_dir(".",force=1)'
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ die "You need to recompile Python with Tkinter support"
+ fi
+ python -c 'import compileall; compileall.compile_dir(".",force=1)'
}
-src_install () {
- # Figures out the destination directory, based on Python's version
- # installed.
- local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
- local pmwdir="/usr/lib/python${pv}/site-packages/Pmw"
-
- local dir
- for dir in `find . -type d`
- do
- # Skip the doc directory
- if [ `basename "${dir}"` = "doc" ]
- then
- continue
- fi
- insinto "${pmwdir}/${dir}"
- cd "${dir}"
- # Install all regular files in this dir
- local file
- for file in *
- do
- [ -f "${file}" ] && doins "${file}"
- done
- cd "${S}"
- done
-
- dodoc README
- local docdir=`find . -type d -name doc`
- dohtml -a html,gif,py "${docdir}"/*
+src_install() {
+ # Figures out the destination directory, based on Python's version installed.
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local pmwdir="/usr/lib/python${pv}/site-packages/Pmw"
+
+ local dir
+ for dir in `find . -type d` ; do
+ # Skip the doc directory
+ [ `basename "${dir}"` = "doc" ] && continue
+
+ insinto "${pmwdir}/${dir}"
+ cd "${dir}"
+ # Install all regular files in this dir
+ local file
+ for file in * ; do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ dodoc README
+ local docdir=`find . -type d -name doc`
+ dohtml -a html,gif,py "${docdir}"/*
}