summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-07 16:55:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-07 16:55:13 +0000
commitbacc2fa03e04c7f7cb2b0b0809b65b894b671cbc (patch)
treeea7ff2a2bd161abacf8329eb7b792c27ee5e3fc5 /dev-python
parentDelete older ebuilds. (diff)
downloadhistorical-bacc2fa03e04c7f7cb2b0b0809b65b894b671cbc.tar.gz
historical-bacc2fa03e04c7f7cb2b0b0809b65b894b671cbc.tar.bz2
historical-bacc2fa03e04c7f7cb2b0b0809b65b894b671cbc.zip
Delete older ebuilds.
Package-Manager: portage-2.2.0_alpha14/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jinja/ChangeLog7
-rw-r--r--dev-python/jinja/files/jinja2-2.3.1-python-3.2.patch14
-rw-r--r--dev-python/jinja/files/jinja2-2.3.1-python-3.patch84
-rw-r--r--dev-python/jinja/jinja-2.3.1.ebuild67
-rw-r--r--dev-python/jinja/jinja-2.5.2.ebuild62
-rw-r--r--dev-python/jinja/jinja-2.5.ebuild56
-rw-r--r--dev-python/mechanize/ChangeLog6
-rw-r--r--dev-python/mechanize/mechanize-0.2.2.ebuild40
-rw-r--r--dev-python/mechanize/mechanize-0.2.3.ebuild40
9 files changed, 11 insertions, 365 deletions
diff --git a/dev-python/jinja/ChangeLog b/dev-python/jinja/ChangeLog
index bb93564eb32d..305a6a000715 100644
--- a/dev-python/jinja/ChangeLog
+++ b/dev-python/jinja/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jinja
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/ChangeLog,v 1.44 2011/01/07 16:17:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/ChangeLog,v 1.45 2011/01/07 16:51:54 arfrever Exp $
+
+ 07 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -jinja-2.3.1.ebuild, -files/jinja2-2.3.1-python-3.2.patch,
+ -files/jinja2-2.3.1-python-3.patch, -jinja-2.5.ebuild, -jinja-2.5.2.ebuild:
+ Delete.
07 Jan 2011; Brent Baude <ranger@gentoo.org> jinja-2.5.5.ebuild:
Marking jinja-2.5.5 ppc for bug 347109
diff --git a/dev-python/jinja/files/jinja2-2.3.1-python-3.2.patch b/dev-python/jinja/files/jinja2-2.3.1-python-3.2.patch
deleted file mode 100644
index ae5cee1ccea4..000000000000
--- a/dev-python/jinja/files/jinja2-2.3.1-python-3.2.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=306215
-http://dev.pocoo.org/hg/jinja2-main/rev/2e4934235d58
-
---- jinja2/testsuite/debug.py
-+++ jinja2/testsuite/debug.py
-@@ -30,7 +30,7 @@
- \{\{ fail\(\) \}\}
- File ".*?debug.pyc?", line \d+, in <lambda>
- tmpl\.render\(fail=lambda: 1 / 0\)
--ZeroDivisionError: int(eger)? division or modulo by zero
-+ZeroDivisionError: (int(eger)? )?division (or modulo )?by zero
- ''')
-
- def test_syntax_error(self):
diff --git a/dev-python/jinja/files/jinja2-2.3.1-python-3.patch b/dev-python/jinja/files/jinja2-2.3.1-python-3.patch
deleted file mode 100644
index fd161a07753c..000000000000
--- a/dev-python/jinja/files/jinja2-2.3.1-python-3.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- jinja2/_speedups.c
-+++ jinja2/_speedups.c
-@@ -123,7 +123,10 @@
- PyObject *s = NULL, *rv = NULL, *html;
-
- /* we don't have to escape integers, bools or floats */
-- if (PyInt_CheckExact(text) || PyLong_CheckExact(text) ||
-+ if (PyLong_CheckExact(text) ||
-+#if PY_MAJOR_VERSION < 3
-+ PyInt_CheckExact(text) ||
-+#endif
- PyFloat_CheckExact(text) || PyBool_Check(text) ||
- text == Py_None)
- return PyObject_CallFunctionObjArgs(markup, text, NULL);
-@@ -139,7 +142,11 @@
- /* otherwise make the object unicode if it isn't, then escape */
- PyErr_Clear();
- if (!PyUnicode_Check(text)) {
-+#if PY_MAJOR_VERSION >= 3
-+ PyObject *unicode = PyObject_Str(text);
-+#else
- PyObject *unicode = PyObject_Unicode(text);
-+#endif
- if (!unicode)
- return NULL;
- s = escape_unicode((PyUnicodeObject*)unicode);
-@@ -159,7 +166,11 @@
- soft_unicode(PyObject *self, PyObject *s)
- {
- if (!PyUnicode_Check(s))
-+#if PY_MAJOR_VERSION >= 3
-+ return PyObject_Str(s);
-+#else
- return PyObject_Unicode(s);
-+#endif
- Py_INCREF(s);
- return s;
- }
-@@ -207,15 +218,45 @@
- {NULL, NULL, 0, NULL} /* Sentinel */
- };
-
-+#if PY_MAJOR_VERSION >= 3
-+static struct PyModuleDef module_definition = {
-+ PyModuleDef_HEAD_INIT,
-+ "jinja2._speedups",
-+ NULL,
-+ -1,
-+ module_methods,
-+ NULL,
-+ NULL,
-+ NULL,
-+ NULL
-+};
-+#endif
-+
-
- #ifndef PyMODINIT_FUNC /* declarations for DLL import/export */
- #define PyMODINIT_FUNC void
- #endif
- PyMODINIT_FUNC
-+#if PY_MAJOR_VERSION >= 3
-+PyInit__speedups(void)
-+#else
- init_speedups(void)
-+#endif
- {
- if (!init_constants())
-+#if PY_MAJOR_VERSION >= 3
-+ return NULL;
-+#else
- return;
-+#endif
-
-+#if PY_MAJOR_VERSION >= 3
-+ PyObject *module = PyModule_Create(&module_definition);
-+#else
- Py_InitModule3("jinja2._speedups", module_methods, "");
-+#endif
-+
-+#if PY_MAJOR_VERSION >= 3
-+ return module;
-+#endif
- }
diff --git a/dev-python/jinja/jinja-2.3.1.ebuild b/dev-python/jinja/jinja-2.3.1.ebuild
deleted file mode 100644
index 857edc5dad71..000000000000
--- a/dev-python/jinja/jinja-2.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.3.1.ebuild,v 1.3 2010/08/18 09:53:34 djc Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils
-
-MY_PN="Jinja2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
-HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
-SRC_URI="mirror://pypi/J/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-SLOT="0"
-IUSE="doc examples i18n test"
-
-CDEPEND="dev-python/setuptools"
-DEPEND="${CDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND="${CDEPEND}
- i18n? ( >=dev-python/Babel-0.9.3 )"
-
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
-DOCS="CHANGES"
-PYTHON_MODNAME="jinja2"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/jinja2-2.3.1-python-3.patch"
- epatch "${FILESDIR}/jinja2-2.3.1-python-3.2.patch"
-}
-
-src_compile(){
- distutils_src_compile
-
- if use doc; then
- cd "${S}/docs"
- PYTHONPATH=.. emake html || die "Building of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
-
- # Don't install C sources.
- find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" | xargs rm -f
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- # Eliminate .pyc files going into /usr/share
- find examples -name "*.pyc" -print0 | xargs -0 rm -fr
-
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Failed to install examples"
- fi
-}
diff --git a/dev-python/jinja/jinja-2.5.2.ebuild b/dev-python/jinja/jinja-2.5.2.ebuild
deleted file mode 100644
index 1b610a4944c8..000000000000
--- a/dev-python/jinja/jinja-2.5.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.5.2.ebuild,v 1.11 2010/11/27 17:48:01 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils
-
-MY_PN="Jinja2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
-HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
-SRC_URI="mirror://pypi/J/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples i18n test"
-
-RDEPEND="dev-python/setuptools
- dev-python/markupsafe
- i18n? ( >=dev-python/Babel-0.9.3 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_GLOBAL_OPTIONS=("--with-debugsupport")
-DOCS="CHANGES"
-PYTHON_MODNAME="jinja2"
-
-src_prepare() {
- distutils_src_prepare
- find examples -name "*.py[co]" -print0 | xargs -0 rm -f
-}
-
-src_compile(){
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
- python_clean_installation_image
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Failed to install examples"
- fi
-}
diff --git a/dev-python/jinja/jinja-2.5.ebuild b/dev-python/jinja/jinja-2.5.ebuild
deleted file mode 100644
index 24c20807b745..000000000000
--- a/dev-python/jinja/jinja-2.5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.5.ebuild,v 1.7 2010/08/18 09:53:34 djc Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils
-
-MY_PN="Jinja2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
-HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
-SRC_URI="mirror://pypi/J/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples i18n test"
-
-RDEPEND="dev-python/setuptools
- i18n? ( >=dev-python/Babel-0.9.3 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
-DOCS="CHANGES"
-PYTHON_MODNAME="jinja2"
-
-src_compile(){
- distutils_src_compile
-
- if use doc; then
- cd docs
- einfo "Generation of documentation"
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
- python_clean_installation_image
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Failed to install examples"
- fi
-}
diff --git a/dev-python/mechanize/ChangeLog b/dev-python/mechanize/ChangeLog
index dcf03221b9f7..868f135d1641 100644
--- a/dev-python/mechanize/ChangeLog
+++ b/dev-python/mechanize/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mechanize
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.36 2011/01/07 16:30:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.37 2011/01/07 16:55:13 arfrever Exp $
+
+ 07 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -mechanize-0.2.2.ebuild, -mechanize-0.2.3.ebuild:
+ Delete.
07 Jan 2011; Brent Baude <ranger@gentoo.org> mechanize-0.2.4.ebuild:
Marking mechanize-0.2.4 ppc for bug 348078
diff --git a/dev-python/mechanize/mechanize-0.2.2.ebuild b/dev-python/mechanize/mechanize-0.2.2.ebuild
deleted file mode 100644
index 01cd7b821789..000000000000
--- a/dev-python/mechanize/mechanize-0.2.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.2.2.ebuild,v 1.4 2010/09/28 15:26:40 ranger Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils eutils
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
-SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DOCS="docs/*.txt"
-
-src_test() {
- testing() {
- # Ignore warnings (http://github.com/jjlee/mechanize/issues/issue/13).
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" -Wignore test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- # Fix some paths.
- sed -i -e 's:../styles/:styles/:g' docs/html/*
- dohtml -r docs/html/ docs/styles
-
- distutils_src_install
-}
diff --git a/dev-python/mechanize/mechanize-0.2.3.ebuild b/dev-python/mechanize/mechanize-0.2.3.ebuild
deleted file mode 100644
index a0bbd36bacb1..000000000000
--- a/dev-python/mechanize/mechanize-0.2.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.2.3.ebuild,v 1.1 2010/10/17 20:36:53 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils eutils
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
-SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DOCS="docs/*.txt"
-
-src_test() {
- testing() {
- # Ignore warnings (http://github.com/jjlee/mechanize/issues/issue/13).
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" -Wignore test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- # Fix some paths.
- sed -e "s:../styles/:styles/:g" -i docs/html/* || die "sed failed"
- dohtml -r docs/html/ docs/styles || die "dohtml failed"
-}