summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-02 17:20:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-02 17:20:52 +0000
commitbf1d46ca2900d6080d93caf562dcbb7784a4c26f (patch)
tree1027053bad08a70365baad5bb7aabfbdacc83a7e /dev-python
parentNew ebuild. (diff)
downloadhistorical-bf1d46ca2900d6080d93caf562dcbb7784a4c26f.tar.gz
historical-bf1d46ca2900d6080d93caf562dcbb7784a4c26f.tar.bz2
historical-bf1d46ca2900d6080d93caf562dcbb7784a4c26f.zip
Exclude tests when romio is not set on mpi. Remove sources of documentation. Keyword amd64-linux, x86-linux
Package-Manager: portage-2.2.01.20796-prefix/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpi4py/ChangeLog8
-rw-r--r--dev-python/mpi4py/metadata.xml13
-rw-r--r--dev-python/mpi4py/mpi4py-1.2.2.ebuild41
-rw-r--r--dev-python/mpi4py/mpi4py-1.3.ebuild22
4 files changed, 26 insertions, 58 deletions
diff --git a/dev-python/mpi4py/ChangeLog b/dev-python/mpi4py/ChangeLog
index eabafa59614c..b46022d2241a 100644
--- a/dev-python/mpi4py/ChangeLog
+++ b/dev-python/mpi4py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mpi4py
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.8 2012/02/23 09:52:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.9 2012/08/02 17:20:52 bicatali Exp $
+
+ 02 Aug 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> -mpi4py-1.2.2.ebuild,
+ metadata.xml, mpi4py-1.3.ebuild:
+ Exclude tests when romio is not set on mpi. Remove sources of documentation.
+ Keyword amd64-linux, x86-linux
23 Feb 2012; Patrick Lauer <patrick@gentoo.org> mpi4py-1.2.2.ebuild,
mpi4py-1.3.ebuild:
@@ -43,4 +48,3 @@
+metadata.xml:
Initial import. Closing bug #189376, thanks Marek and Ben Bannier for
their initial work
-
diff --git a/dev-python/mpi4py/metadata.xml b/dev-python/mpi4py/metadata.xml
index 31fa7d68fc3e..2709655e56c1 100644
--- a/dev-python/mpi4py/metadata.xml
+++ b/dev-python/mpi4py/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <longdescription lang="en">MPI for Python (mpi4py) provides bindings of the Message Passing
+<herd>python</herd>
+<longdescription lang="en">MPI for Python (mpi4py) provides bindings of the Message Passing
Interface (MPI) standard for the Python programming language,
allowing any Python program to exploit multiple processors.
This package is constructed on top of the MPI-1/MPI-2 specification
@@ -11,8 +11,9 @@
collective (broadcasts, scatters, gathers) communications of any
picklable Python object as well as optimized communications of
Python object exposing the single-segment buffer interface (NumPy
- arrays, builtin bytes/string/array objects).</longdescription>
- <upstream>
- <remote-id type="google-code">mpi4py</remote-id>
- </upstream>
+ arrays, builtin bytes/string/array objects).
+</longdescription>
+<upstream>
+ <remote-id type="google-code">mpi4py</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/dev-python/mpi4py/mpi4py-1.2.2.ebuild b/dev-python/mpi4py/mpi4py-1.2.2.ebuild
deleted file mode 100644
index 04a144d64b89..000000000000
--- a/dev-python/mpi4py/mpi4py-1.2.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.2.2.ebuild,v 1.3 2012/02/23 09:52:20 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7-pypy-* *-jython"
-
-inherit distutils
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
-SRC_URI="http://mpi4py.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND="virtual/mpi"
-RDEPEND="${DEPEND}"
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" mpiexec -n 2 "$(PYTHON)" test/runalltest.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- insinto /usr/share/doc/${PF}/html
- doins -r docs/* || die "doins failed"
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r demo/* || die "doins failed"
- fi
-}
diff --git a/dev-python/mpi4py/mpi4py-1.3.ebuild b/dev-python/mpi4py/mpi4py-1.3.ebuild
index 9d9094977083..59db9074365c 100644
--- a/dev-python/mpi4py/mpi4py-1.3.ebuild
+++ b/dev-python/mpi4py/mpi4py-1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3.ebuild,v 1.3 2012/02/23 09:52:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3.ebuild,v 1.4 2012/08/02 17:20:52 bicatali Exp $
EAPI="4"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.7-pypy-* *-jython"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Message Passing Interface for Python"
HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
@@ -14,26 +14,30 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
DEPEND="virtual/mpi"
RDEPEND="${DEPEND}"
+src_prepare() {
+ # not needed on install
+ rm -r docs/source || die
+}
+
src_test() {
+ local exclude
+ has_version virtual/mpi[romio] || exclude="--exclude=file --exclude=class"
testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" mpiexec -n 2 "$(PYTHON)" test/runtests.py
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
+ mpiexec -n 2 "$(PYTHON)" test/runtests.py ${exclude}
}
python_execute_function testing
}
src_install() {
distutils_src_install
-
- if use doc; then
- insinto /usr/share/doc/${PF}/html
- doins -r docs/*
- fi
+ use doc && dohtml -r docs/*
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins -r demo/*