summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 02:41:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 02:41:34 +0000
commite7569c8c57253adfaccbe1c2ac2b72f50158972b (patch)
treea443c6b4ce774ebd444c53546359187635f5a9df /dev-python
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-e7569c8c57253adfaccbe1c2ac2b72f50158972b.tar.gz
historical-e7569c8c57253adfaccbe1c2ac2b72f50158972b.tar.bz2
historical-e7569c8c57253adfaccbe1c2ac2b72f50158972b.zip
Simplify code.
Package-Manager: portage-13887-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4.ebuild19
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild18
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.ebuild15
3 files changed, 20 insertions, 32 deletions
diff --git a/dev-python/PyQt4/PyQt4-4.5.4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
index b998e1f1e9ae..d0babbfdffc0 100644
--- a/dev-python/PyQt4/PyQt4-4.5.4.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4.ebuild,v 1.4 2009/08/02 17:44:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4.ebuild,v 1.5 2009/08/04 02:38:20 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -59,18 +59,18 @@ src_prepare() {
python_copy_sources
- prepare_package() {
+ preparation() {
if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
rm -fr pyuic/uic/port_v2
else
rm -fr pyuic/uic/port_v3
fi
}
- python_execute_function -s prepare_package
+ python_execute_function -s preparation
}
src_configure() {
- configure_package() {
+ configuration() {
local myconf="$(get_python) configure.py
--confirm-license
--bindir=/usr/bin
@@ -100,25 +100,22 @@ src_configure() {
sed -i -e "/^LFLAGS/s:-Wl,-rpath,${S}-${PYTHON_ABI}/qpy/${pkg}::" ${pkg}/Makefile || die "failed to fix rpath issues"
done
}
- python_execute_function -s configure_package
+ python_execute_function -s configuration
}
src_compile() {
- build_package() {
- emake
- }
- python_execute_function -s build_package
+ python_execute_function -d -s
}
src_install() {
python_need_rebuild
- install_package() {
+ installation() {
# INSTALL_ROOT is needed for the QtDesigner module,
# the other Makefiles use DESTDIR.
emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
}
- python_execute_function -s install_package
+ python_execute_function -s installation
dodoc ChangeLog NEWS THANKS || die
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
index 13a6954b2340..35840e28f2fc 100644
--- a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.3 2009/08/02 00:45:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.4 2009/08/04 02:34:49 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
-inherit python multilib
+inherit multilib python
DESCRIPTION="Python bindings for the D-Bus messagebus."
HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
@@ -37,26 +37,20 @@ src_prepare() {
}
src_configure() {
- configure_package() {
+ configuration() {
econf --docdir=/usr/share/doc/dbus-python-${PV}
}
- python_execute_function -s configure_package
+ python_execute_function -s configuration
}
src_compile() {
- build_package() {
- emake
- }
- python_execute_function -s build_package
+ python_execute_function -d -s
}
src_install() {
python_need_rebuild
- install_package() {
- emake DESTDIR="${D}" install
- }
- python_execute_function -s install_package
+ python_execute_function -d -s
if use examples; then
insinto /usr/share/doc/${PF}/
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
index c141d64951f0..34c6e859dbe2 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.4 2009/08/02 05:32:25 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.5 2009/08/04 02:41:34 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -33,7 +33,7 @@ src_prepare() {
}
src_configure() {
- configure_package() {
+ configuration() {
local myconf="$(get_python) configure.py
--destdir=$(python_get_sitedir)/PyQt$(use qt4 && echo 4)
-n /usr/include
@@ -43,21 +43,18 @@ src_configure() {
echo ${myconf}
${myconf}
}
- python_execute_function -s configure_package
+ python_execute_function -s configuration
}
src_compile() {
- build_package() {
+ building() {
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
}
- python_execute_function -s build_package
+ python_execute_function -s building
}
src_install() {
python_need_rebuild
- install_package() {
- emake DESTDIR="${D}" install
- }
- python_execute_function -s install_package
+ python_execute_function -d -s
}