summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-27 08:24:39 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-27 08:24:39 +0000
commit34b0a2be846caa39690fc8f8f7712e4a16983a80 (patch)
treebe6ee7efcaf08b87f9d99bd08262819e414f3ce4 /dev-ruby/activemodel
parentInstall header files, #396099; thanks Michael (kensington) for the patch (diff)
downloadhistorical-34b0a2be846caa39690fc8f8f7712e4a16983a80.tar.gz
historical-34b0a2be846caa39690fc8f8f7712e4a16983a80.tar.bz2
historical-34b0a2be846caa39690fc8f8f7712e4a16983a80.zip
Version bump. Drop keywords due to new dependencies, bug 396177.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.1.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index a23fb14151e9..851be6d81239 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.16 2011/11/19 10:55:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.17 2011/12/27 08:20:02 graaff Exp $
+
+*activemodel-3.1.3 (27 Dec 2011)
+
+ 27 Dec 2011; Hans de Graaff <graaff@gentoo.org> +activemodel-3.1.3.ebuild:
+ Version bump. Drop keywords due to new dependencies, bug 396177.
*activemodel-3.0.11 (19 Nov 2011)
diff --git a/dev-ruby/activemodel/activemodel-3.1.3.ebuild b/dev-ruby/activemodel/activemodel-3.1.3.ebuild
new file mode 100644
index 000000000000..a2a45de1a6dd
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.1.3.ebuild,v 1.1 2011/12/27 08:20:02 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/i18n-0.6.0:0.6
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}