summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-09-12 05:58:12 +0000
committerHans de Graaff <graaff@gentoo.org>2008-09-12 05:58:12 +0000
commite6a8df99a793e5e9e55d90ac070a52ad7a8a5a6c (patch)
treeb934afd2d3ffdcb703d053825f1013a9209f596a /dev-ruby/activerecord
parentVersion bump. Cleanup (diff)
downloadhistorical-e6a8df99a793e5e9e55d90ac070a52ad7a8a5a6c.tar.gz
historical-e6a8df99a793e5e9e55d90ac070a52ad7a8a5a6c.tar.bz2
historical-e6a8df99a793e5e9e55d90ac070a52ad7a8a5a6c.zip
Version bump for Rails 2.0.4, bug #237385
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.0.4.ebuild21
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index cb8db5483b6f..bd171dd776f6 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.79 2008/07/13 09:00:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.80 2008/09/12 05:56:06 graaff Exp $
+
+*activerecord-2.0.4 (12 Sep 2008)
+
+ 12 Sep 2008; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.0.4.ebuild:
+ Version bump for Rails 2.0.4, bug #237385
13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
-activerecord-1.14.4.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-2.0.4.ebuild b/dev-ruby/activerecord/activerecord-2.0.4.ebuild
new file mode 100644
index 000000000000..be0f6894fa45
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.0.4.ebuild,v 1.1 2008/09/12 05:56:06 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ =dev-ruby/activesupport-2.0.4
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"