summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-08 19:38:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-08 19:38:36 +0000
commit7fedf211c4ec12d335f7f36905b9c846f72d1d48 (patch)
tree4face65a901fb00e0b0f3dd2d51864c26e9453ff /dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild
parentAdd missing virtual/ruby-test-unit dependency to stay on the safe side; fix t... (diff)
downloadhistorical-7fedf211c4ec12d335f7f36905b9c846f72d1d48.tar.gz
historical-7fedf211c4ec12d335f7f36905b9c846f72d1d48.tar.bz2
historical-7fedf211c4ec12d335f7f36905b9c846f72d1d48.zip
Fix specifications so that they can be used with bundler (required for radiant-1). Also add mocha to the list of test dependencies for 3.0, found while installing the wrong slot.
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild b/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild
new file mode 100644
index 000000000000..a0de5bae5292
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild,v 1.1 2011/12/08 19:38:36 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as well
+ # as fixing the dependencies for i18n to use the correct slot. It
+ # also edits the metadata file so that the dependencies are added to
+ # the specification, which is required for bundler to pick them up
+ # (which in turn is required by radiant 1.0.0rc3 to
+ # work). Furthermore remove the references to the vendorized copies
+ # from the specification, to be safe.
+ epatch "${FILESDIR}"/${PN}-2.3.14-unvendorize.patch
+ sed -i -e '/\/vendor\//d' ../metadata
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}