summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-04 18:00:19 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-04 18:00:19 +0000
commit197b66ebc862f20ed56e537d3451f4b8f9d8cb5b (patch)
tree111d67c99b6e149908641a729eb6b7b88ac143d3 /dev-ruby/arel/arel-2.0.10-r1.ebuild
parentAdd missing variable to avoid sandbox violation. Old ebuild removed (diff)
downloadhistorical-197b66ebc862f20ed56e537d3451f4b8f9d8cb5b.tar.gz
historical-197b66ebc862f20ed56e537d3451f4b8f9d8cb5b.tar.bz2
historical-197b66ebc862f20ed56e537d3451f4b8f9d8cb5b.zip
Fix version number in gem specification.
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/arel/arel-2.0.10-r1.ebuild')
-rw-r--r--dev-ruby/arel/arel-2.0.10-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/arel/arel-2.0.10-r1.ebuild b/dev-ruby/arel/arel-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..fed504454982
--- /dev/null
+++ b/dev-ruby/arel/arel-2.0.10-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/arel-2.0.10-r1.ebuild,v 1.1 2011/07/04 18:00:19 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.markdown"
+
+# Use the ruby specifications since parsing the yaml metadata causes
+# jruby to crash.
+RUBY_FAKEGEM_GEMSPEC="arel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Arel is a Relational Algebra for Ruby."
+HOMEPAGE="http://github.com/rails/arel"
+LICENSE="MIT"
+SLOT="2.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/hoe-2.6.2 )
+ test? (
+ >=dev-ruby/hoe-2.6.2
+ virtual/ruby-minitest
+ )"
+
+all_ruby_prepare() {
+ # Fix the version number in the gemspec.
+ sed -i -e 's/2.0.9.20110222133018/2.0.10/' arel.gemspec || die
+}