summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-08-07 22:35:18 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-08-07 22:35:18 +0000
commit5e498bcdfd1a01e062884b69302971737a071ac1 (patch)
tree3152fc80ddf2ca0bde14709837c42f02fc9da77d /dev-ruby/bluecloth/bluecloth-1.0.0.ebuild
parentVersion bump. (diff)
downloadhistorical-5e498bcdfd1a01e062884b69302971737a071ac1.tar.gz
historical-5e498bcdfd1a01e062884b69302971737a071ac1.tar.bz2
historical-5e498bcdfd1a01e062884b69302971737a071ac1.zip
Initial import. Ebuild submitted by Ben de Groot <ben@stijlstek.nl> in bug #101561.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-ruby/bluecloth/bluecloth-1.0.0.ebuild')
-rw-r--r--dev-ruby/bluecloth/bluecloth-1.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bluecloth/bluecloth-1.0.0.ebuild b/dev-ruby/bluecloth/bluecloth-1.0.0.ebuild
new file mode 100644
index 000000000000..b3b5889a97fd
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-1.0.0.ebuild,v 1.1 2005/08/07 22:35:18 citizen428 Exp $
+
+inherit ruby gems
+
+MY_P="BlueCloth-${PV}"
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+SRC_URI="http://www.deveiate.org/code/${MY_P}.gem"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+USE_RUBY="ruby18"
+DEPEND=">=dev-lang/ruby-1.8"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_postinst() {
+ einfo "This package was installed using a 'gem'."
+ einfo "If you are intending to write code which"
+ einfo "requires ${PN}, you will need to"
+ einfo
+ einfo "require 'rubygems'"
+ einfo
+ einfo "before requiring '${PN}'."
+}