summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-09 06:18:11 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-09 06:18:11 +0000
commit61c12e6ff2daa5fef9d8ccc7ac4cce1a5587cb60 (patch)
tree1d06408bf25223a648488cf4349ab8e1917541f1 /dev-ruby/crack/crack-0.1.8.ebuild
parentDo not install sequence.h twice by Dominik Köppl, patch by Fabian Henze (bug... (diff)
downloadhistorical-61c12e6ff2daa5fef9d8ccc7ac4cce1a5587cb60.tar.gz
historical-61c12e6ff2daa5fef9d8ccc7ac4cce1a5587cb60.tar.bz2
historical-61c12e6ff2daa5fef9d8ccc7ac4cce1a5587cb60.zip
Version bump.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/crack/crack-0.1.8.ebuild')
-rw-r--r--dev-ruby/crack/crack-0.1.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/crack/crack-0.1.8.ebuild b/dev-ruby/crack/crack-0.1.8.ebuild
new file mode 100644
index 000000000000..a54c1e5f30c6
--- /dev/null
+++ b/dev-ruby/crack/crack-0.1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.1.8.ebuild,v 1.1 2010/07/09 06:18:11 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails."
+HOMEPAGE="http://rubyforge.org/projects/crack"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/matchy )"
+
+all_ruby_prepare() {
+ # By default this gem wants to use the fork of matchy from the
+ # same author of itself, but we don't package that (as it's
+ # neither released on gemcutter nor tagged). On the other hand it
+ # works fine with the mcmire gem that we package as
+ # dev-ruby/matchy.
+ sed -i -e 's:jnunemaker-matchy:mcmire-matchy:' test/test_helper.rb || die
+}