summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-27 18:56:11 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-27 18:56:11 +0000
commit3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb (patch)
tree13661a4830d69d21c981a68b9145dce8abe4db58 /dev-ruby/daemons
parentFix #349840 (incorrect symlinks to /bin/rpm) (diff)
downloadhistorical-3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb.tar.gz
historical-3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb.tar.bz2
historical-3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb.zip
Drop ruby19 support to create a stable candidate.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/daemons')
-rw-r--r--dev-ruby/daemons/ChangeLog8
-rw-r--r--dev-ruby/daemons/daemons-1.1.0-r1.ebuild30
-rw-r--r--dev-ruby/daemons/daemons-1.1.0.ebuild4
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-ruby/daemons/ChangeLog b/dev-ruby/daemons/ChangeLog
index deb1e0e89de0..70822b71fb7e 100644
--- a/dev-ruby/daemons/ChangeLog
+++ b/dev-ruby/daemons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.48 2010/10/08 09:41:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.49 2010/12/27 18:54:51 graaff Exp $
+
+*daemons-1.1.0-r1 (27 Dec 2010)
+
+ 27 Dec 2010; Hans de Graaff <graaff@gentoo.org> daemons-1.1.0.ebuild,
+ +daemons-1.1.0-r1.ebuild:
+ Drop ruby19 support to create a stable candidate.
08 Oct 2010; Hans de Graaff <graaff@gentoo.org> -daemons-1.0.10-r1.ebuild:
Remove old version.
diff --git a/dev-ruby/daemons/daemons-1.1.0-r1.ebuild b/dev-ruby/daemons/daemons-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..60c06237e362
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0-r1.ebuild,v 1.1 2010/12/27 18:54:51 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="http://daemons.rubyforge.org/"
+
+LICENSE="|| ( Ruby GPL-2 ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/daemons/daemons-1.1.0.ebuild b/dev-ruby/daemons/daemons-1.1.0.ebuild
index 36b8844e255c..fc649979320a 100644
--- a/dev-ruby/daemons/daemons-1.1.0.ebuild
+++ b/dev-ruby/daemons/daemons-1.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0.ebuild,v 1.1 2010/07/19 06:53:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0.ebuild,v 1.2 2010/12/27 18:54:51 graaff Exp $
EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
RUBY_FAKEGEM_DOCDIR="html"