summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-26 23:05:14 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-26 23:05:14 +0000
commit97431ebdba23f8d3f7bed59fb974471bb664ff40 (patch)
treea291cd38e2033f2cee7f65fa26a359c8af5593d4 /dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild
parentRemoving roedu from mirror://rubyforge, dead. (diff)
downloadhistorical-97431ebdba23f8d3f7bed59fb974471bb664ff40.tar.gz
historical-97431ebdba23f8d3f7bed59fb974471bb664ff40.tar.bz2
historical-97431ebdba23f8d3f7bed59fb974471bb664ff40.zip
Initial import, ebuild by /me.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild')
-rw-r--r--dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild b/dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild
new file mode 100644
index 000000000000..28e5fb8c1317
--- /dev/null
+++ b/dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-sqlite/dbd-sqlite-0.1.2.ebuild,v 1.1 2009/08/26 23:05:14 a3li Exp $
+
+inherit "ruby"
+
+DESCRIPTION="The SQLite database driver (DBD) for Ruby/DBI"
+HOMEPAGE="http://ruby-dbi.rubyforge.org"
+SRC_URI="mirror://rubyforge/ruby-dbi/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="virtual/ruby"
+RDEPEND="${DEPEND}
+ >=dev-ruby/ruby-dbi-0.4.2
+ dev-ruby/sqlite-ruby"
+
+USE_RUBY="ruby18"
+
+src_test() {
+ elog "The tests require additional configuration."
+ elog "You will find them in /usr/share/${PN}/test/"
+ elog "Be sure to read the file called DBD_TESTS."
+}
+
+src_install() {
+ ruby setup.rb install \
+ --prefix="${D}" || die "setup.rb install failed"
+
+ if use test; then
+ dodir /usr/share/${PN}
+ cp -pPR test "${D}/usr/share/${PN}" || die "couldn't copy tests"
+ fi
+}