summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-26 06:50:09 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-26 06:50:09 +0000
commit0edf08237bac6ee6e35f64e1fc83644ac0b66855 (patch)
tree7627df8b6f952185ad02d26b937a1ff38df7910d /dev-ruby/mash/mash-0.1.1-r1.ebuild
parentRemove old version. (diff)
downloadhistorical-0edf08237bac6ee6e35f64e1fc83644ac0b66855.tar.gz
historical-0edf08237bac6ee6e35f64e1fc83644ac0b66855.tar.bz2
historical-0edf08237bac6ee6e35f64e1fc83644ac0b66855.zip
Convert to ruby-fakegem.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/mash/mash-0.1.1-r1.ebuild')
-rw-r--r--dev-ruby/mash/mash-0.1.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/mash/mash-0.1.1-r1.ebuild b/dev-ruby/mash/mash-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..bb16e532ea07
--- /dev/null
+++ b/dev-ruby/mash/mash-0.1.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mash/mash-0.1.1-r1.ebuild,v 1.1 2010/06/26 06:50:09 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mash is an extended Hash that gives simple pseudo-object functionality."
+HOMEPAGE="http://github.com/mbleigh/mash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"