summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-28 14:31:20 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-28 14:31:20 +0000
commita59123183b450c07f4351d2b954ad36af4bc9fb1 (patch)
treeaf65a7e4a1cb0b2c096eba654de890943732fe46 /dev-ruby/ohai/ohai-0.5.6-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-a59123183b450c07f4351d2b954ad36af4bc9fb1.tar.gz
historical-a59123183b450c07f4351d2b954ad36af4bc9fb1.tar.bz2
historical-a59123183b450c07f4351d2b954ad36af4bc9fb1.zip
Run specs. Depend on json version newer than 1.4.3 which is broken with ohai. Remove patch: it breaks the specs and there is no associated problem description or bug report.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/ohai/ohai-0.5.6-r1.ebuild')
-rw-r--r--dev-ruby/ohai/ohai-0.5.6-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ohai/ohai-0.5.6-r1.ebuild b/dev-ruby/ohai/ohai-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..867f387bcf01
--- /dev/null
+++ b/dev-ruby/ohai/ohai-0.5.6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.5.6-r1.ebuild,v 1.1 2010/08/28 14:31:20 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ohai profiles your system and emits JSON"
+HOMEPAGE="http://wiki.opscode.com/display/ohai"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/extlib
+ >=dev-ruby/json-1.4.4
+ dev-ruby/mixlib-cli
+ dev-ruby/mixlib-config
+ dev-ruby/mixlib-log
+ dev-ruby/systemu"