summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-03-14 21:41:51 +0000
committerHans de Graaff <graaff@gentoo.org>2011-03-14 21:41:51 +0000
commitc864d8cb36931e866693388bcd17cd35f8b27bfe (patch)
tree07130955fe21d45136d2fdb9fe290e76b06d2f83 /dev-ruby/pg/pg-0.9.0-r1.ebuild
parentMarked ~x86-linux (diff)
downloadhistorical-c864d8cb36931e866693388bcd17cd35f8b27bfe.tar.gz
historical-c864d8cb36931e866693388bcd17cd35f8b27bfe.tar.bz2
historical-c864d8cb36931e866693388bcd17cd35f8b27bfe.zip
Tests can only be run with FEATURES=userpriv.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/pg/pg-0.9.0-r1.ebuild')
-rw-r--r--dev-ruby/pg/pg-0.9.0-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-ruby/pg/pg-0.9.0-r1.ebuild b/dev-ruby/pg/pg-0.9.0-r1.ebuild
index 7320c17b189b..db91f80cf25f 100644
--- a/dev-ruby/pg/pg-0.9.0-r1.ebuild
+++ b/dev-ruby/pg/pg-0.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.10 2011/03/13 16:06:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.11 2011/03/14 21:41:51 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18"
@@ -51,8 +51,14 @@ each_ruby_compile() {
}
each_ruby_test() {
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- ${RUBY} -Ilib -S spec -Du -fs spec/*_spec.rb || die "spec failed"
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S spec -Du -fs spec/*_spec.rb || die "spec failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
}
+