summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 10:05:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 10:05:53 +0000
commit1db34fa0b4f6dfecc0564cb4a30761233833a0d0 (patch)
tree9b49e2a53852b279c84474a74a6ee792d42896f9 /dev-ruby/pg
parentInitial commit, ebuild written by me (bug #224983). (diff)
downloadhistorical-1db34fa0b4f6dfecc0564cb4a30761233833a0d0.tar.gz
historical-1db34fa0b4f6dfecc0564cb4a30761233833a0d0.tar.bz2
historical-1db34fa0b4f6dfecc0564cb4a30761233833a0d0.zip
Cleanup old version.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog5
-rw-r--r--dev-ruby/pg/pg-0.8.0.ebuild53
2 files changed, 4 insertions, 54 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 34e5b4bfb764..5e72dcf34515 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.16 2010/05/23 10:03:10 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.17 2010/07/29 10:00:56 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org> -pg-0.8.0.ebuild:
+ Cleanup old version.
23 May 2010; Alex Legler <a3li@gentoo.org> pg-0.9.0-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/pg/pg-0.8.0.ebuild b/dev-ruby/pg/pg-0.8.0.ebuild
deleted file mode 100644
index 9250e70282bd..000000000000
--- a/dev-ruby/pg/pg-0.8.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.8.0.ebuild,v 1.8 2010/02/13 20:43:30 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19"
-
-# Tests will always fail because they need access to the pgsql server
-RUBY_FAKEGEM_TEST_TASK="spec"
-RESTRICT="test"
-
-RUBY_FAKEGEM_DOCDIR="doc/rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND="dev-db/postgresql-base"
-DEPEND="${RDEPEND}"
-
-all_ruby_prepare() {
- sed -i \
- -e '/ext_helper/s:^:#:' \
- -e '/setup_extension/s:^:#:' \
- -e '/task :spec =>/s:^:#:' \
- Rakefile || die "Rakefile fix failed"
-}
-
-each_ruby_compile() {
- pushd "${S}"/ext
- ${RUBY} extconf.rb || die "extconf.rb failed"
- emake || die "emake failed"
- popd
-}
-
-each_ruby_install() {
- ruby_fakegem_newins ext/pg.so lib/pg.so
- each_fakegem_install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc sample/*.rb || die "sample installation failed"
-}