summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:17:54 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:17:54 +0000
commit682f6b40aa02611430138e650a6e4f8075aaee1e (patch)
tree8eea9794bb8ee9b2959741cd607485c656c463c3 /dev-ruby/rdtool
parentA=-fix, try->die, tab-fixes, stylefixes, ... (diff)
downloadhistorical-682f6b40aa02611430138e650a6e4f8075aaee1e.tar.gz
historical-682f6b40aa02611430138e650a6e4f8075aaee1e.tar.bz2
historical-682f6b40aa02611430138e650a6e4f8075aaee1e.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-ruby/rdtool')
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.6.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/dev-ruby/rdtool/rdtool-0.6.6.ebuild b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
index 1ff00901a518..c22c821ef9ba 100644
--- a/dev-ruby/rdtool/rdtool-0.6.6.ebuild
+++ b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/rdtool-0.6.6.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/rdtool-0.6.6.ebuild,v 1.2 2001/11/10 12:17:54 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Fast string scanning library for Ruby"
-SRC_URI="http://www2.pos.to/~tosh/ruby/rdtool/archive/${A}"
+SRC_URI="http://www2.pos.to/~tosh/ruby/rdtool/archive/${P}.tar.gz"
HOMEPAGE="http://www2.pos.to/~tosh/ruby/rdtool/en/index.html"
DEPEND=">=dev-lang/ruby-1.6.1
@@ -15,17 +14,15 @@ DEPEND=">=dev-lang/ruby-1.6.1
>=dev-ruby/optparse-0.7.5"
src_compile() {
- cd ${S}
- try ruby rdtoolconf.rb
- try make
+ ruby rdtoolconf.rb || die
+ make || die
}
src_install () {
- cd ${S}
- chmod 755 rd2
- dobin rd2
+ chmod 755 rd2
+ dobin rd2
- cd ${S}/rd
- insinto /usr/lib/ruby/site_ruby/1.6/rd
- doins dot.rd2rc *.rb
+ cd ${S}/rd
+ insinto /usr/lib/ruby/site_ruby/1.6/rd
+ doins dot.rd2rc *.rb
}