summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 16:38:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 16:38:15 +0000
commitbab922fb93f5f91c1f5131c463e8bddc99b9b8e8 (patch)
treec4e344a24babebfcf1ac05ab60a0c8a719e2930a /dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild
parentMarking zentest-4.2.1 ~ppc64 for bug 298367 (diff)
downloadhistorical-bab922fb93f5f91c1f5131c463e8bddc99b9b8e8.tar.gz
historical-bab922fb93f5f91c1f5131c463e8bddc99b9b8e8.tar.bz2
historical-bab922fb93f5f91c1f5131c463e8bddc99b9b8e8.zip
Version bump.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild')
-rw-r--r--dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild b/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild
new file mode 100644
index 000000000000..8e98f1372a15
--- /dev/null
+++ b/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild,v 1.1 2010/01/13 16:38:15 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+# would be spec, but it needs to be in the same filesystem tree as
+# rspec (and cannot use the install-reduced code), so we cannot run
+# them for now.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Contribute.rdoc History.rdoc README.rdoc Upgrade.rdoc TODO.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="generators"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec's official Ruby on Rails plugin"
+HOMEPAGE="http://rspec.info/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-1.3.0 >=dev-ruby/rack-1.0.0"
+
+# Without this the whole Rakefile fails, so it's a general dependency
+# and not just a test dependency.
+ruby_add_bdepend doc dev-util/cucumber