summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-13 18:04:03 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-13 18:04:03 +0000
commitc0ef3a05fe81a56e3ac5a303058a5656558eb469 (patch)
treeb2a1b6054f2ab934772b8508c986c01dab86c997 /dev-ruby/rspec/rspec-2.0.0_beta22.ebuild
parentVersion bump (diff)
downloadhistorical-c0ef3a05fe81a56e3ac5a303058a5656558eb469.tar.gz
historical-c0ef3a05fe81a56e3ac5a303058a5656558eb469.tar.bz2
historical-c0ef3a05fe81a56e3ac5a303058a5656558eb469.zip
Initial import of rspec-2.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rspec/rspec-2.0.0_beta22.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-2.0.0_beta22.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-2.0.0_beta22.ebuild b/dev-ruby/rspec/rspec-2.0.0_beta22.ebuild
new file mode 100644
index 000000000000..c203ef4d92eb
--- /dev/null
+++ b/dev-ruby/rspec/rspec-2.0.0_beta22.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.0.0_beta22.ebuild,v 1.1 2010/09/13 18:04:03 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_VERSION="2.0.0.beta.22"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="mirror://rubygems/${PN}-${RUBY_FAKEGEM_VERSION}.gem"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ ~dev-ruby/rspec-core-${PV}
+ ~dev-ruby/rspec-expectations-${PV}
+ ~dev-ruby/rspec-mocks-${PV}"