summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-02-17 10:34:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-02-17 10:34:56 +0000
commit077f280a1089e42c33018d152cbc3bd2326d0ed6 (patch)
tree922a6016913441c88721b9728e0584b430e9b719 /dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild
parentAdd GEM variant ebuild, so that other packages can use it. This ebuild tries ... (diff)
downloadhistorical-077f280a1089e42c33018d152cbc3bd2326d0ed6.tar.gz
historical-077f280a1089e42c33018d152cbc3bd2326d0ed6.tar.bz2
historical-077f280a1089e42c33018d152cbc3bd2326d0ed6.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild')
-rw-r--r--dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild b/dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild
new file mode 100644
index 000000000000..3d528433661d
--- /dev/null
+++ b/dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-irc/ruby-irc-1.0.7.ebuild,v 1.1 2007/02/17 10:33:17 robbat2 Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+MY_PN="Ruby-IRC"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Ruby-IRC is a framework for connecting and comunicating with IRC servers."
+HOMEPAGE="http://rubyforge.org/projects/ruby-irc"
+SRC_URI="http://gems.rubyforge.org/gems/${MY_P}.gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5"