summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2006-06-22 13:38:53 +0000
committerMatthew Marlowe <mattm@gentoo.org>2006-06-22 13:38:53 +0000
commit06b7c4739e2b38960776dcffd4dfe0c7d9dc632c (patch)
treed291fb1e245203ac220091ea7517793d96ef7ccd /dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild
parentMove myconf population in src_compile rather than global scope. (diff)
downloadhistorical-06b7c4739e2b38960776dcffd4dfe0c7d9dc632c.tar.gz
historical-06b7c4739e2b38960776dcffd4dfe0c7d9dc632c.tar.bz2
historical-06b7c4739e2b38960776dcffd4dfe0c7d9dc632c.zip
Continuing initial commit.
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild')
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild
new file mode 100644
index 000000000000..5b0386560f17
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ruby-oci8-0.1.15.ebuild,v 1.1 2006/06/22 13:38:53 mattm Exp $
+
+inherit ruby
+
+DESCRIPTION="A Ruby extension library to use Oracle"
+HOMEPAGE="http://rubyforge.org/projects/ruby-oci8/"
+SRC_URI="http://rubyforge.org/frs/download.php/10081/ruby-oci8-${PV}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+USE_RUBY="ruby18 ruby19"
+
+RDEPEND="dev-db/oracle-instantclient-basic
+ dev-db/oracle-instantclient-sqlplus"
+DEPEND="virtual/ruby ${RDEPEND}"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+}