summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-26 03:20:30 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-26 03:20:30 +0000
commit3da83ca8f7fb533677b16862795e38ef4323909b (patch)
tree5cd0e0fb6452539766fd06eb453dafbfe149fd88 /dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
parentBump (diff)
downloadhistorical-3da83ca8f7fb533677b16862795e38ef4323909b.tar.gz
historical-3da83ca8f7fb533677b16862795e38ef4323909b.tar.bz2
historical-3da83ca8f7fb533677b16862795e38ef4323909b.zip
Initial ebuild.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild')
-rw-r--r--dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
new file mode 100644
index 000000000000..37511e61150c
--- /dev/null
+++ b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild,v 1.1 2013/11/26 03:20:26 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for GNTP(Growl Notification Transport Protocol)"
+HOMEPAGE="https://github.com/snaka/ruby_gntp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rr )"
+
+all_ruby_prepare() {
+ mv test spec || die
+ sed -i -e "s/Spec::Runner/RSpec/" \
+ -e "s#\.\./lib/##"\
+ spec/ruby_gntp_spec.rb || die
+
+}