summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-28 11:20:54 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-28 11:20:54 +0000
commit60417f7a05399017d9254273f890f7516949b7fe (patch)
tree79974cae1d72303b84511dee7022e9446f8d4a57 /dev-ruby/test-unit
parentUpdate jython dependency as jython slotted. (diff)
downloadhistorical-60417f7a05399017d9254273f890f7516949b7fe.tar.gz
historical-60417f7a05399017d9254273f890f7516949b7fe.tar.bz2
historical-60417f7a05399017d9254273f890f7516949b7fe.zip
Version bump.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog7
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.5.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 14ad4d7ccf66..3f2918d4a6ca 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.50 2012/01/03 18:16:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.51 2012/01/28 11:13:14 graaff Exp $
+
+*test-unit-2.4.5 (28 Jan 2012)
+
+ 28 Jan 2012; Hans de Graaff <graaff@gentoo.org> +test-unit-2.4.5.ebuild:
+ Version bump.
03 Jan 2012; Jeroen Roovers <jer@gentoo.org> test-unit-2.4.0.ebuild,
test-unit-2.4.2.ebuild, test-unit-2.4.3.ebuild:
diff --git a/dev-ruby/test-unit/test-unit-2.4.5.ebuild b/dev-ruby/test-unit/test-unit-2.4.5.ebuild
new file mode 100644
index 000000000000..44a083d6d144
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.5.ebuild,v 1.1 2012/01/28 11:13:14 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+# redcloth is also needed to build documentation, but not available for
+# jruby. Since we build documentation with the main ruby implementation
+# only we skip the dependency for jruby in this roundabout way, assuming
+# that jruby won't be the main ruby.
+USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 doc" "( dev-ruby/redcloth )"
+USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 doc" "( dev-ruby/redcloth )"
+USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 doc" "( dev-ruby/redcloth )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
+}