summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 02:34:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 02:34:32 +0000
commit11e72e5828db5991c26ad8287da7e95a56141b40 (patch)
tree152f5a73b348203f97d2ddbad61c1cf2d4753006 /dev-ruby/tmail/tmail-1.2.3.1.ebuild
parentMove patch to dev.gentoo.org as it's quite big. (diff)
downloadhistorical-11e72e5828db5991c26ad8287da7e95a56141b40.tar.gz
historical-11e72e5828db5991c26ad8287da7e95a56141b40.tar.bz2
historical-11e72e5828db5991c26ad8287da7e95a56141b40.zip
Make it install properly the binary extension on Ruby Enterprise as well. Respect CFLAGS/LDFLAGS.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/tmail/tmail-1.2.3.1.ebuild')
-rw-r--r--dev-ruby/tmail/tmail-1.2.3.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-ruby/tmail/tmail-1.2.3.1.ebuild b/dev-ruby/tmail/tmail-1.2.3.1.ebuild
deleted file mode 100644
index 24e3bf126c77..000000000000
--- a/dev-ruby/tmail/tmail-1.2.3.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.3.1.ebuild,v 1.11 2010/05/22 22:40:08 a3li Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README CHANGES NOTES"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An email handling library"
-HOMEPAGE="http://rubyforge.org/projects/tmail/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="debug"
-
-# Tests seem to be broken with the new encoding handling from Ruby,
-# need to be verified twice; code seems to work anyway.
-RESTRICT=test
-
-ruby_add_bdepend "
- dev-ruby/racc
- test? ( >=dev-ruby/mocha-0.9.5 )"
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) == "ruby18" ]]; then
- pushd ext/tmailscanner/tmail
- ${RUBY} extconf.rb || die "extconf failed"
- emake || die "emake extension failed"
- popd
- fi
-
- emake -C lib/tmail $(use debug && echo DEBUG=true) parser.rb || die "emake failed"
-}
-
-each_ruby_install() {
- # We cannot use the recursive install because there are
- # racc source files and a makefile.
- find lib -name '*.rb' | while read file; do
- ruby_fakegem_newins $file $file
- done
-
- if [[ $(basename ${RUBY}) == "ruby18" ]]; then
- ruby_fakegem_newins ext/tmailscanner/tmail/tmailscanner.so lib/tmail/tmailscanner.so
- fi
-
- ruby_fakegem_genspec
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc sample/* || die
-}