summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-27 07:05:18 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-27 07:05:18 +0000
commit4acf5a36d9f1a91404f9e07f6d2f94e9c5b671c1 (patch)
tree95a97c3c7e0e3ffd73d100ee2f8727b0250cd9e5 /dev-ruby/zentest/zentest-4.7.0.ebuild
parentRemove old versions. (diff)
downloadhistorical-4acf5a36d9f1a91404f9e07f6d2f94e9c5b671c1.tar.gz
historical-4acf5a36d9f1a91404f9e07f6d2f94e9c5b671c1.tar.bz2
historical-4acf5a36d9f1a91404f9e07f6d2f94e9c5b671c1.zip
Version bump.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/zentest/zentest-4.7.0.ebuild')
-rw-r--r--dev-ruby/zentest/zentest-4.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/zentest/zentest-4.7.0.ebuild b/dev-ruby/zentest/zentest-4.7.0.ebuild
new file mode 100644
index 000000000000..38e3bf8d53c3
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/zentest/zentest-4.7.0.ebuild,v 1.1 2012/04/27 07:05:18 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ZenTest provides tools to support testing: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="http://rubyforge.org/projects/zentest/"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"