summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-20 08:45:42 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-20 08:45:42 +0000
commit0746b110a705d40b97d002715c07bcb5b0085aeb (patch)
tree6b7ee9b6ea3c52a80d504490fba874944744e494 /dev-ruby
parentAdd package. (diff)
downloadhistorical-0746b110a705d40b97d002715c07bcb5b0085aeb.tar.gz
historical-0746b110a705d40b97d002715c07bcb5b0085aeb.tar.bz2
historical-0746b110a705d40b97d002715c07bcb5b0085aeb.zip
Version bump.
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gherkin/ChangeLog7
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.11.ebuild72
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.12.0.ebuild37
4 files changed, 121 insertions, 2 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 21cb06b49290..489a0ecb1332 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.25 2011/08/08 06:05:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.26 2011/08/20 08:41:57 graaff Exp $
+
+*gherkin-2.4.11 (20 Aug 2011)
+
+ 20 Aug 2011; Hans de Graaff <graaff@gentoo.org> +gherkin-2.4.11.ebuild:
+ Version bump.
*gherkin-2.4.6 (08 Aug 2011)
diff --git a/dev-ruby/gherkin/gherkin-2.4.11.ebuild b/dev-ruby/gherkin/gherkin-2.4.11.ebuild
new file mode 100644
index 000000000000..ce90091bf4c7
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.4.11.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.11.ebuild,v 1.1 2011/08/20 08:41:57 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+RUBY_S="cucumber-gherkin-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/awesome_print-0.4.0
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.0.0
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.7.2 )"
+
+ruby_add_rdepend ">=dev-ruby/json-1.4.6"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index f2769ac04f8f..3e80a3a0702a 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.118 2011/08/10 04:56:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.119 2011/08/20 08:45:42 graaff Exp $
+
+*hoe-2.12.0 (20 Aug 2011)
+
+ 20 Aug 2011; Hans de Graaff <graaff@gentoo.org> +hoe-2.12.0.ebuild:
+ Version bump.
*hoe-2.11.0 (10 Aug 2011)
diff --git a/dev-ruby/hoe/hoe-2.12.0.ebuild b/dev-ruby/hoe/hoe-2.12.0.ebuild
new file mode 100644
index 000000000000..17a00566f9a7
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.12.0.ebuild,v 1.1 2011/08/20 08:45:42 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"
+
+all_ruby_prepare() {
+ # Make test regexp more lenient to cover the way we name the binaries.
+ sed -i -e 's/sudo gem/sudo .?gem/' -e 's/\^gem/^.?gem/' test/test_hoe.rb || die
+}