summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-21 20:12:22 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-21 20:12:22 +0000
commit118b0959b8631ab5380b1da036f9838f209950b5 (patch)
tree1439656940bb12457887eb76e95482294ebd0c46 /dev-ruby
parentFix tests when Rails 3 is also present. (diff)
downloadhistorical-118b0959b8631ab5380b1da036f9838f209950b5.tar.gz
historical-118b0959b8631ab5380b1da036f9838f209950b5.tar.bz2
historical-118b0959b8631ab5380b1da036f9838f209950b5.zip
Version bump for Rails 2.3.11.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.11.ebuild34
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.3.11.ebuild58
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.11.ebuild57
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.11.ebuild35
-rw-r--r--dev-ruby/activesupport/ChangeLog12
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.11.ebuild38
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.11.ebuild63
12 files changed, 329 insertions, 6 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 2fc9784d0cba..2341e5874246 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.153 2011/02/21 19:42:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.154 2011/02/21 20:10:46 graaff Exp $
+
+*actionmailer-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
actionmailer-2.3.10.ebuild, +files/actionmailer-2.3.10-rails3.patch:
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild
new file mode 100644
index 000000000000..8d71c436b449
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild,v 1.1 2011/02/21 20:10:46 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.3.10-rails3.patch" )
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 21e1e047e555..ff7dabe79366 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.170 2011/02/20 15:55:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.171 2011/02/21 20:09:50 graaff Exp $
+
+*actionpack-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
20 Feb 2011; Hans de Graaff <graaff@gentoo.org> actionpack-2.3.10.ebuild,
+files/actionpack-2.3.10-i18n-0.4.2.patch,
diff --git a/dev-ruby/actionpack/actionpack-2.3.11.ebuild b/dev-ruby/actionpack/actionpack-2.3.11.ebuild
new file mode 100644
index 000000000000..bf3dcb417341
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.11.ebuild,v 1.1 2011/02/21 20:09:50 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-rails3.patch" "${PN}-2.3.10-i18n-0.4.2.patch" )
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-1.1.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.7
+ dev-ruby/activerecord:${SLOT}
+ dev-ruby/actionmailer:${SLOT}
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ # This tries to load a “vendorized” copy of activerecord that we
+ # will never have. It can now also use a normally installed
+ # version but these tests fail.
+ sed -i -e '/PATH_TO_AR/s:^:#:' -e 's/self.able_to_connect = true/self.able_to_connect = false/' test/active_record_unit.rb || die
+
+ # Fix the testsuite, the symlink is not present in the gem for
+ # some reason
+ ln -s ../../symlink_parent test/fixtures/layout_tests/layouts/symlinked
+
+ # MemCacheStore tests no longer fail gracefully, and it's unlikely for
+ # someone to have them running anyway, so remove them for now.
+ rm test/controller/session/mem_cache_store_test.rb || die
+
+ # Fix tests when run against i18n 0.4.2 which ignores locale
+ # definitions with an empty data section.
+ sed -i -e 's/, {}/, {:test => "test"}/' test/template/render_test.rb || die
+}
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 25cb11cbbca4..aec6304099cc 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.150 2011/02/21 19:55:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.151 2011/02/21 20:11:53 graaff Exp $
+
+*activerecord-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
activerecord-2.3.10.ebuild, +files/activerecord-2.3.10-rails3.patch:
diff --git a/dev-ruby/activerecord/activerecord-2.3.11.ebuild b/dev-ruby/activerecord/activerecord-2.3.11.ebuild
new file mode 100644
index 000000000000..02bbae39c7d6
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.11.ebuild,v 1.1 2011/02/21 20:11:53 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 \
+ ruby_add_rdepend "
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 480c0d78f537..b7fb185fca13 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.76 2011/02/21 20:04:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.77 2011/02/21 20:11:22 graaff Exp $
+
+*activeresource-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
activeresource-2.3.10.ebuild, +files/activeresource-2.3.10-rails3.patch:
diff --git a/dev-ruby/activeresource/activeresource-2.3.11.ebuild b/dev-ruby/activeresource/activeresource-2.3.11.ebuild
new file mode 100644
index 000000000000..25e0721552c0
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.11.ebuild,v 1.1 2011/02/21 20:11:22 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 3477ea0cc41a..0ffb8f7692de 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.134 2011/02/13 21:19:11 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.135 2011/02/21 20:08:48 graaff Exp $
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
+
+*activesupport-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
13 Feb 2011; Thomas Kahle <tomka@gentoo.org> activesupport-3.0.3.ebuild:
keyworded ~x86 per bug 351835
diff --git a/dev-ruby/activesupport/activesupport-2.3.11.ebuild b/dev-ruby/activesupport/activesupport-2.3.11.ebuild
new file mode 100644
index 000000000000..7e36aa392729
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.11.ebuild,v 1.1 2011/02/21 20:08:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use the correct
+ # slot.
+ epatch "${FILESDIR}"/${PN}-2.3.9-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index eabb64768996..ad4dba81b3f6 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.185 2011/02/13 21:11:07 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.186 2011/02/21 20:12:22 graaff Exp $
+
+*rails-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org> +rails-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
13 Feb 2011; Thomas Kahle <tomka@gentoo.org> rails-3.0.3.ebuild:
keyworded ~x86 per bug 351835
diff --git a/dev-ruby/rails/rails-2.3.11.ebuild b/dev-ruby/rails/rails-2.3.11.ebuild
new file mode 100644
index 000000000000..ad2ced64b0a5
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.11.ebuild,v 1.1 2011/02/21 20:12:22 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die "Could not remove reference to unavailable documentation template."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}