summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-09-04 06:25:13 +0000
committerHans de Graaff <graaff@gentoo.org>2009-09-04 06:25:13 +0000
commit8d428352abd774eb503af2a0d72cb0c2bdc8355c (patch)
treeff1ef1e8e0cd457e93747744241ee020f0b70a46 /dev-ruby
parentremove old (diff)
downloadhistorical-8d428352abd774eb503af2a0d72cb0c2bdc8355c.tar.gz
historical-8d428352abd774eb503af2a0d72cb0c2bdc8355c.tar.bz2
historical-8d428352abd774eb503af2a0d72cb0c2bdc8355c.zip
Version bump.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.4.ebuild18
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.4.ebuild22
4 files changed, 54 insertions, 2 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 0ecb7093953b..feff86530bd8 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.108 2009/08/16 14:29:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.109 2009/09/04 06:21:33 graaff Exp $
+
+*actionmailer-2.3.4 (04 Sep 2009)
+
+ 04 Sep 2009; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.3.4.ebuild:
+ Version bump: fix security issues reported in #283396.
16 Aug 2009; Raúl Porcel <armin76@gentoo.org> actionmailer-2.3.3.ebuild:
Add ~ia64 wrt #279123
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.4.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.4.ebuild
new file mode 100644
index 000000000000..4e5dfa362c4e
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.4.ebuild,v 1.1 2009/09/04 06:21:33 graaff Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~dev-ruby/actionpack-2.3.4
+ >=dev-lang/ruby-1.8.6"
+RDEPEND="${DEPEND}"
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 40fd237dd7d4..3dfa124df88b 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.105 2009/07/22 07:08:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.106 2009/09/04 06:25:13 graaff Exp $
+
+*activerecord-2.3.4 (04 Sep 2009)
+
+ 04 Sep 2009; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.4.ebuild:
+ Version bump: fix security issues reported in #283396.
*activerecord-2.3.3 (22 Jul 2009)
diff --git a/dev-ruby/activerecord/activerecord-2.3.4.ebuild b/dev-ruby/activerecord/activerecord-2.3.4.ebuild
new file mode 100644
index 000000000000..fd4a6a0d9359
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.4.ebuild,v 1.1 2009/09/04 06:25:13 graaff Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-2.3.4"
+RDEPEND="${DEPEND}
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"