summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-11-19 19:51:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-11-19 19:51:33 +0000
commitbe77463fb00f1012058af481187521e1cb0b0a12 (patch)
tree673a9da23254d51ed26839c0e8fcc91dd50fa148 /dev-ruby
parentadd a patch that fixes a bug that would give invalid premature eof errors, th... (diff)
downloadhistorical-be77463fb00f1012058af481187521e1cb0b0a12.tar.gz
historical-be77463fb00f1012058af481187521e1cb0b0a12.tar.bz2
historical-be77463fb00f1012058af481187521e1cb0b0a12.zip
Add httpclient-2.1.2. httpclient replaces http-access2, and is developed by the same upstream.
I'll take care of it and of moving from the old to the new one. Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/httpclient/ChangeLog12
-rw-r--r--dev-ruby/httpclient/files/digest-httpclient-2.1.23
-rw-r--r--dev-ruby/httpclient/httpclient-2.1.2.ebuild33
-rw-r--r--dev-ruby/httpclient/metadata.xml8
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
new file mode 100644
index 000000000000..a9babbebb392
--- /dev/null
+++ b/dev-ruby/httpclient/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-ruby/httpclient
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.1 2007/11/19 19:51:32 flameeyes Exp $
+
+*httpclient-2.1.2 (19 Nov 2007)
+
+ 19 Nov 2007; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ +httpclient-2.1.2.ebuild:
+ Add httpclient-2.1.2. httpclient replaces http-access2, and is developed by
+ the same upstream. I'll take care of it and of moving from the old to the
+ new one.
+
diff --git a/dev-ruby/httpclient/files/digest-httpclient-2.1.2 b/dev-ruby/httpclient/files/digest-httpclient-2.1.2
new file mode 100644
index 000000000000..7b9ef6fefe28
--- /dev/null
+++ b/dev-ruby/httpclient/files/digest-httpclient-2.1.2
@@ -0,0 +1,3 @@
+MD5 999a5c00fcad067b9d65a074e58a85e0 httpclient-2.1.2.tar.gz 103518
+RMD160 5ad6dfff5e12e4d401873bf96e7189bc85413ea2 httpclient-2.1.2.tar.gz 103518
+SHA256 19a3e966f31f0427e5e92d24bd516dc65b96f530a6468e63e1466188b38a1f9f httpclient-2.1.2.tar.gz 103518
diff --git a/dev-ruby/httpclient/httpclient-2.1.2.ebuild b/dev-ruby/httpclient/httpclient-2.1.2.ebuild
new file mode 100644
index 000000000000..7a533e503963
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.2.ebuild,v 1.1 2007/11/19 19:51:32 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="http://dev.ctor.org/http-access2/"
+SRC_URI="http://dev.ctor.org/download/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+USE_RUBY="any"
+
+S="${WORKDIR}/${P}"
+
+RDEPEND="!dev-ruby/http-access2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s%^SITELIBDIR = %SITELIBDIR = \"${D}\" + %" install.rb
+}
+
+src_compile() { :; }
+
+src_install() {
+ my_sitedir=$(ruby -rrbconfig -e 'print Config::CONFIG["sitedir"]')
+ mkdir -p "${D}/${my_sitedir}/1.8"
+ ruby install.rb
+ erubydoc
+}
diff --git a/dev-ruby/httpclient/metadata.xml b/dev-ruby/httpclient/metadata.xml
new file mode 100644
index 000000000000..9c44ddd40005
--- /dev/null
+++ b/dev-ruby/httpclient/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+ <email>flameeyes@gentoo.org</email>
+</maintainer>
+</pkgmetadata>