summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 07:27:12 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 07:27:12 +0000
commitf7b9c7efa4e90c1d1f5b473d7b15a063a6c44a3f (patch)
tree6295a5b2460e71017e8d64ffb6a296abeac64f5e /dev-ruby
parentcmake variable LIB was renamed to GMXLIB (diff)
downloadhistorical-f7b9c7efa4e90c1d1f5b473d7b15a063a6c44a3f.tar.gz
historical-f7b9c7efa4e90c1d1f5b473d7b15a063a6c44a3f.tar.bz2
historical-f7b9c7efa4e90c1d1f5b473d7b15a063a6c44a3f.zip
Version bump for Rails 3.0.10
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.10.ebuild55
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.10.ebuild44
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.10.ebuild61
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.10.ebuild41
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.10.ebuild43
10 files changed, 275 insertions, 5 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 0c54f292579b..fb9e659ca740 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.192 2011/09/09 08:09:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.193 2011/09/28 07:24:44 graaff Exp $
+
+*actionpack-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org> actionpack-3.0.9.ebuild:
Marked ~sparc-solaris
diff --git a/dev-ruby/actionpack/actionpack-3.0.10.ebuild b/dev-ruby/actionpack/actionpack-3.0.10.ebuild
new file mode 100644
index 000000000000..44eacc336a73
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.10.ebuild,v 1.1 2011/09/28 07:24:44 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2:0
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.5.0:0.5
+ >=dev-ruby/rack-1.2.1:1.2
+ >=dev-ruby/rack-mount-0.6.14:0.6
+ >=dev-ruby/rack-test-0.5.7:0.5
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' actionpack.gemspec || die
+}
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index e279744c843a..6aecd0fadff5 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.13 2011/09/09 07:32:55 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.14 2011/09/28 07:22:20 graaff Exp $
+
+*activemodel-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org> activemodel-3.0.9.ebuild:
Marked ~sparc-solaris
diff --git a/dev-ruby/activemodel/activemodel-3.0.10.ebuild b/dev-ruby/activemodel/activemodel-3.0.10.ebuild
new file mode 100644
index 000000000000..a5cbd7bde72f
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.10.ebuild,v 1.1 2011/09/28 07:22:20 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.5.0:0.5"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index b1d6313ca65f..84d06660c176 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.170 2011/09/09 08:33:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.171 2011/09/28 07:27:12 graaff Exp $
+
+*activerecord-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +activerecord-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org>
activerecord-3.0.9.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-3.0.10.ebuild b/dev-ruby/activerecord/activerecord-3.0.10.ebuild
new file mode 100644
index 000000000000..6d2fb5a68be6
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.10.ebuild,v 1.1 2011/09/28 07:27:12 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.10-r1:2.0
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
+ mysql? ( dev-ruby/mysql2:0.2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 26f8201e8174..f8167e632146 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.95 2011/09/09 07:51:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.96 2011/09/28 07:26:14 graaff Exp $
+
+*activeresource-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org>
activeresource-3.0.9.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-3.0.10.ebuild b/dev-ruby/activeresource/activeresource-3.0.10.ebuild
new file mode 100644
index 000000000000..d1ac0c1da025
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.10.ebuild,v 1.1 2011/09/28 07:26:14 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index ed5a5893eb9d..ed7692cd0994 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.153 2011/09/09 07:37:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.154 2011/09/28 07:20:53 graaff Exp $
+
+*activesupport-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org>
activesupport-3.0.9.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-3.0.10.ebuild b/dev-ruby/activesupport/activesupport-3.0.10.ebuild
new file mode 100644
index 000000000000..ecd93d5d8b9c
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.10.ebuild,v 1.1 2011/09/28 07:20:53 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}