summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-01-05 21:16:19 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-01-05 21:16:19 +0000
commit5fd3af61eec89063efc973ed479c256f750ed575 (patch)
tree263ca364d1681867a3a3f15113337aa431e86b28 /dev-scheme/gambit/gambit-4.4.0.ebuild
parentversions bump; vdradmin-am-3.6.2 stabel on x86; clean up old versions (diff)
downloadhistorical-5fd3af61eec89063efc973ed479c256f750ed575.tar.gz
historical-5fd3af61eec89063efc973ed479c256f750ed575.tar.bz2
historical-5fd3af61eec89063efc973ed479c256f750ed575.zip
enable single-host by default and remove option to enable gcc-opts
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'dev-scheme/gambit/gambit-4.4.0.ebuild')
-rw-r--r--dev-scheme/gambit/gambit-4.4.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-scheme/gambit/gambit-4.4.0.ebuild b/dev-scheme/gambit/gambit-4.4.0.ebuild
index ffdce12cc1d3..bdbd6fab6d5f 100644
--- a/dev-scheme/gambit/gambit-4.4.0.ebuild
+++ b/dev-scheme/gambit/gambit-4.4.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.0.ebuild,v 1.2 2008/12/31 03:24:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.0.ebuild,v 1.3 2009/01/05 21:16:19 hkbst Exp $
-inherit eutils elisp-common check-reqs autotools multilib
+inherit eutils elisp-common check-reqs multilib
MY_PN=gambc
MY_PV=${PV//./_}
@@ -22,9 +22,9 @@ SITEFILE="50gambit-gentoo.el"
S=${WORKDIR}/${MY_P} #-devel
-IUSE="big-iron emacs static"
+IUSE="emacs static"
-pkg_setup() {
+_pkg_setup() {
if use big-iron; then
ewarn "compiling each Scheme module as a single C function"
ewarn "using gcc specific optimizations"
@@ -45,7 +45,7 @@ pkg_setup() {
}
src_compile() {
- econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts) --disable-absolute-shared-libs
+ econf $(use_enable !static shared) --enable-single-host --disable-absolute-shared-libs
emake bootstrap || die