summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlake Matheny <jake@gentoo.org>2004-02-11 22:49:41 +0000
committerBlake Matheny <jake@gentoo.org>2004-02-11 22:49:41 +0000
commit94c07f1c4f9508ac275a8ff5649ec465aac65168 (patch)
tree756caa6e2c7b4ea31717dcc625f01ac79e9c2646 /dev-scheme
parentFixing per bug #41201. Please see bug for more information. (diff)
downloadhistorical-94c07f1c4f9508ac275a8ff5649ec465aac65168.tar.gz
historical-94c07f1c4f9508ac275a8ff5649ec465aac65168.tar.bz2
historical-94c07f1c4f9508ac275a8ff5649ec465aac65168.zip
Move bigloo-lib from dev-lisp to dev-scheme
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo-lib/ChangeLog26
-rw-r--r--dev-scheme/bigloo-lib/Manifest4
-rw-r--r--dev-scheme/bigloo-lib/bigloo-lib-0.17.ebuild84
-rw-r--r--dev-scheme/bigloo-lib/files/digest-bigloo-lib-0.171
-rw-r--r--dev-scheme/bigloo-lib/metadata.xml9
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-scheme/bigloo-lib/ChangeLog b/dev-scheme/bigloo-lib/ChangeLog
new file mode 100644
index 000000000000..6e950f255c59
--- /dev/null
+++ b/dev-scheme/bigloo-lib/ChangeLog
@@ -0,0 +1,26 @@
+# ChangeLog for dev-lisp/bigloo-lib
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo-lib/ChangeLog,v 1.1 2004/02/11 22:49:41 jake Exp $
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
+*bigloo-lib-0.17 (13 Apr 2002)
+
+ 02 Nov 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild :
+ Fixed USE flags, unmasked and marked for testing.
+
+ 01 Aug 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild :
+ Added LICENSE, SLOT and KEYWORDS (apparently Seemant had a finger in this).
+
+ 13 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild files/digest-bigloo-lib-0.17 :
+
+ Bigloo-lib is a set of libraries for Bigloo, the Scheme programming language
+ compiler (http://kaolin.unice.fr/bigloo/). Most of the libraries are
+ ready-to-use interfaces for various C-based packages, such as C runtime
+ library, Gtk++, LDAP client API or XML parser API. Other are done entirely
+ in `pure Scheme', such as HTTP library and NODE library.
+
+ Besides, the bigloo-lib provides a comfortable framework to configure,
+ compile, install and deploy Bigloo (in particular, system-dependent)
+ libraries, so it is quite a good place to put code created by other Bigloo
+ developers.
diff --git a/dev-scheme/bigloo-lib/Manifest b/dev-scheme/bigloo-lib/Manifest
new file mode 100644
index 000000000000..7ebc930bca8f
--- /dev/null
+++ b/dev-scheme/bigloo-lib/Manifest
@@ -0,0 +1,4 @@
+MD5 d1c9270b0b1036db6fcdee0f29bba280 ChangeLog 1345
+MD5 ca20ef8c9a89ce01047f567813d49954 metadata.xml 252
+MD5 8672d51449aedbd7e771203ddfc7a9b1 bigloo-lib-0.17.ebuild 2176
+MD5 596c454a257327703d728fe508bb58ca files/digest-bigloo-lib-0.17 67
diff --git a/dev-scheme/bigloo-lib/bigloo-lib-0.17.ebuild b/dev-scheme/bigloo-lib/bigloo-lib-0.17.ebuild
new file mode 100644
index 000000000000..c83ce4099858
--- /dev/null
+++ b/dev-scheme/bigloo-lib/bigloo-lib-0.17.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo-lib/bigloo-lib-0.17.ebuild,v 1.1 2004/02/11 22:49:41 jake Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bigloo support libraries"
+SRC_URI="mirror://sourceforge/bigloo-lib/${P}.tar.gz"
+HOMEPAGE="http://bigloo-lib.sf.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc "
+IUSE="nls gtk postgres mysql gtk2 ipcs gd ldap X gdbm expat"
+
+DEPEND=">=dev-scheme/bigloo-2.4
+ X? ( virtual/x11 )
+ gd? ( >=media-libs/libgd-1.8.3 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ nls? ( >=sys-devel/gettext-0.11.1 )
+ gtk2? ( =x11-libs/gtk+-2* )
+ ldap? ( >=net-nds/openldap-2.0.18 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ >=dev-libs/expat-1.95.4
+ "
+src_compile() {
+ local myconf
+ # readline support is flaky
+# myconf="--with-commandline"
+ use gd && \
+ myconf="${myconf} --with-gd" \
+ || myconf="${myconf} --without-gd"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use gtk2 \
+ && myconf="${myconf} --with-gtk2" \
+ || myconf="${myconf} --without-gtk2"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+
+ use nls \
+ && myconf="${myconf} --with-iconv --with-gettext" \
+ || myconf="${myconf} --without-nls --without-gettext"
+
+ # gdbm support doesn't work
+# use gdbm \
+# && myconf="${myconf} --with-gdbm" \
+# || myconf="${myconf} --without-gdbm"
+ myconf="${myconf} --without-gdbm"
+
+ use mysql \
+ && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+
+ use postgres \
+ && myconf="${myconf} --with-postgres" \
+ || myconf="${myconf} --without-postgres"
+
+# We just force these, as we don't have useflags for them.
+# use expat \
+# && myconf="${myconf} --with-expat" \
+# || myconf="${myconf} --without-expat"
+# use ipcs \
+# && myconf="${myconf} --with-ipcs" \
+# || myconf="${myconf} --without-ipcs"
+
+
+ myconf="${myconf} --with-expat --with-ipcs"
+
+
+ econf ${myconf} || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
diff --git a/dev-scheme/bigloo-lib/files/digest-bigloo-lib-0.17 b/dev-scheme/bigloo-lib/files/digest-bigloo-lib-0.17
new file mode 100644
index 000000000000..d290a17e8b61
--- /dev/null
+++ b/dev-scheme/bigloo-lib/files/digest-bigloo-lib-0.17
@@ -0,0 +1 @@
+MD5 d540c43d31e759bc076901a5175a0e63 bigloo-lib-0.17.tar.gz 660118
diff --git a/dev-scheme/bigloo-lib/metadata.xml b/dev-scheme/bigloo-lib/metadata.xml
new file mode 100644
index 000000000000..98a861dd4547
--- /dev/null
+++ b/dev-scheme/bigloo-lib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-scheme</herd>
+<maintainer>
+ <email>jake@gentoo.org</email>
+ <name>Blake Matheny</name>
+</maintainer>
+</pkgmetadata>