summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-11-30 20:00:19 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-11-30 20:00:19 +0000
commit24486f2aa8e478e0913332024540b11af109e6d7 (patch)
treecf33a1e51e77c136a03634818732bb922b958676 /dev-tcltk/tclx/tclx-8.4-r1.ebuild
parentRev bump fixing bsd build, thanks to Timothy Redaelli <drizzt@gentoo.org> (diff)
downloadhistorical-24486f2aa8e478e0913332024540b11af109e6d7.tar.gz
historical-24486f2aa8e478e0913332024540b11af109e6d7.tar.bz2
historical-24486f2aa8e478e0913332024540b11af109e6d7.zip
Cleaning up and using improved ebuild from bug #95845 thanks to Sebastien Fabbro
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'dev-tcltk/tclx/tclx-8.4-r1.ebuild')
-rw-r--r--dev-tcltk/tclx/tclx-8.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/tclx-8.4-r1.ebuild b/dev-tcltk/tclx/tclx-8.4-r1.ebuild
new file mode 100644
index 000000000000..c433a8c0f87e
--- /dev/null
+++ b/dev-tcltk/tclx/tclx-8.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.4-r1.ebuild,v 1.1 2006/11/30 20:00:19 jokey Exp $
+
+inherit eutils
+
+IUSE="tk threads"
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://tclx.sourceforge.net"
+SRC_URI="mirror://sourceforge/tclx/${PN}${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-lang/tcl-8.4.6
+ tk? ( >=dev-lang/tk-8.4.6 )"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-relid.patch
+ epatch ${FILESDIR}/${P}-varinit.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable tk) \
+ $(use_enable threads) \
+ --enable-shared \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+ doman doc/*.[n3]
+}