summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-07-01 13:07:26 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-07-01 13:07:26 +0000
commit1fec552d06e213339201972d639042e835cf7037 (patch)
tree91262289e028aa705b4fc4320c2a8616fde74c6d /dev-util/aap/aap-1.076.ebuild
parentAdd ~sparc keyword; builds and runs without problem. (diff)
downloadhistorical-1fec552d06e213339201972d639042e835cf7037.tar.gz
historical-1fec552d06e213339201972d639042e835cf7037.tar.bz2
historical-1fec552d06e213339201972d639042e835cf7037.zip
Version bump.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util/aap/aap-1.076.ebuild')
-rw-r--r--dev-util/aap/aap-1.076.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/aap/aap-1.076.ebuild b/dev-util/aap/aap-1.076.ebuild
new file mode 100644
index 000000000000..75b876d59105
--- /dev/null
+++ b/dev-util/aap/aap-1.076.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/aap-1.076.ebuild,v 1.1 2005/07/01 13:07:26 ka0ttic Exp $
+
+IUSE="doc"
+
+DESCRIPTION="Bram Moolenaar's super-make program"
+HOMEPAGE="http://www.a-a-p.org/"
+SRC_URI="mirror://sourceforge/a-a-p/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/python-1.5"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir ${S} && cd ${S} && unzip -q ${DISTDIR}/${A} || die
+}
+
+src_install() {
+ rm doc/*.sgml
+ rm doc/*.pdf
+
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ cp -R doc/* ${D}/usr/share/doc/${PF}/html
+ fi
+ rm doc/*.html
+ rm -fr doc/images
+
+ dodoc doc/*
+ doman aap.1
+ rm -rf doc aap.1
+
+ # Move the remainder directly into the dest tree
+ dodir /usr/share
+ cd ${WORKDIR}
+ mv aap ${D}/usr/share
+
+ # Create a symbolic link for the executable
+ dodir /usr/bin
+ ln -s ../share/aap/aap ${D}/usr/bin/aap
+}