summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-01 17:13:58 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-01 17:13:58 +0000
commit89802a46be3ba0064ca50253f0860cd143bc980c (patch)
treee57dda12778e62aca783a45e3fedc42fd7aa10ac /dev-util/bcpp/bcpp-20090630.ebuild
parentUpdate -Wl,--as-needed patch with OpenMP library finding code from ImageMagic... (diff)
downloadhistorical-89802a46be3ba0064ca50253f0860cd143bc980c.tar.gz
historical-89802a46be3ba0064ca50253f0860cd143bc980c.tar.bz2
historical-89802a46be3ba0064ca50253f0860cd143bc980c.zip
Version bump wrt bug #325481 by Nicolas Kaiser <nikai@nikai.net>
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'dev-util/bcpp/bcpp-20090630.ebuild')
-rw-r--r--dev-util/bcpp/bcpp-20090630.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/bcpp/bcpp-20090630.ebuild b/dev-util/bcpp/bcpp-20090630.ebuild
new file mode 100644
index 000000000000..aa30e73f18cc
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20090630.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bcpp/bcpp-20090630.ebuild,v 1.1 2010/07/01 17:13:58 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="http://invisible-island.net/bcpp/"
+SRC_URI="ftp://invisible-island.net/bcpp/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-20050725-etc-cfg-files.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt || die "dodoc failed"
+
+ # Install our configuration files.
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg || die "doins failed"
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at /etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}