summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-06-17 18:47:27 +0000
committerMichael Januszewski <spock@gentoo.org>2004-06-17 18:47:27 +0000
commit291230de0e0d55911fc220dd9434a5aad1578780 (patch)
treef7bc87b82889a117c7994b5259943091a602e190 /dev-util/biew/biew-5.6.1.ebuild
parentfixed the installation directory (diff)
downloadhistorical-291230de0e0d55911fc220dd9434a5aad1578780.tar.gz
historical-291230de0e0d55911fc220dd9434a5aad1578780.tar.bz2
historical-291230de0e0d55911fc220dd9434a5aad1578780.zip
Added a workaround for bug #53825.
Diffstat (limited to 'dev-util/biew/biew-5.6.1.ebuild')
-rw-r--r--dev-util/biew/biew-5.6.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-util/biew/biew-5.6.1.ebuild b/dev-util/biew/biew-5.6.1.ebuild
index 10bf0cef79bb..b4ab82a2bee1 100644
--- a/dev-util/biew/biew-5.6.1.ebuild
+++ b/dev-util/biew/biew-5.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-5.6.1.ebuild,v 1.2 2004/06/03 17:45:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-5.6.1.ebuild,v 1.3 2004/06/17 18:47:27 spock Exp $
IUSE="slang ncurses"
@@ -28,6 +28,13 @@ src_unpack() {
# sed -i "s/TARGET_OS=.*/TARGET_OS=linux/" makefile
}
+pkg_setup() {
+ if [ -n "`/usr/bin/gcc --version | grep hardened`" ]; then
+ eerror "Currently biew doesn't work when GCC is compiled with the 'hardened' USE flag. Sorry."
+ die "Exiting"
+ fi
+}
+
src_compile() {
cd ${S}