summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-08-02 18:08:37 +0000
committerMichael Januszewski <spock@gentoo.org>2004-08-02 18:08:37 +0000
commit756194ea5b96834832af0e0d07350bd648e6539b (patch)
tree4bf8b0a8a32a65cfd8f89085f653665d1db18a2e /dev-util/biew/biew-5.6.1.ebuild
parentStable on hppa wrt #58612 (diff)
downloadhistorical-756194ea5b96834832af0e0d07350bd648e6539b.tar.gz
historical-756194ea5b96834832af0e0d07350bd648e6539b.tar.bz2
historical-756194ea5b96834832af0e0d07350bd648e6539b.zip
Included a fix from bug #59082 (-fPIC filtering).
Diffstat (limited to 'dev-util/biew/biew-5.6.1.ebuild')
-rw-r--r--dev-util/biew/biew-5.6.1.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-util/biew/biew-5.6.1.ebuild b/dev-util/biew/biew-5.6.1.ebuild
index 4de4b2f76a8d..be3af3bc173f 100644
--- a/dev-util/biew/biew-5.6.1.ebuild
+++ b/dev-util/biew/biew-5.6.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-5.6.1.ebuild,v 1.7 2004/07/20 14:47:39 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-5.6.1.ebuild,v 1.8 2004/08/02 18:08:37 spock Exp $
+inherit flag-o-matic
IUSE="slang ncurses"
DESCRIPTION="A multiplatform portable viewer of binary files with built-in editor in binary, hexadecimal and disassembler modes."
@@ -27,13 +28,6 @@ src_unpack() {
# sed -i "s/TARGET_OS=.*/TARGET_OS=linux/" makefile
}
-pkg_setup() {
- if [ -n "`/usr/bin/gcc --version | grep hardened`" ]; then
- eerror "Currently biew doesn't work when GCC is compiled with the 'hardened' USE flag. Sorry."
- die "Exiting"
- fi
-}
-
src_compile() {
cd ${S}
@@ -47,6 +41,8 @@ src_compile() {
scrnlib="vt100"
fi
+ filter-flags -fPIC
+
emake HOST_CFLAGS="${CFLAGS}" \
TARGET_SCREEN_LIB=${scrnlib} || die
}