summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-12-15 12:26:30 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-12-15 12:26:30 +0000
commit7573f63b26125ac309d2d67070f33768f81451be (patch)
tree655b448e97d3e2a111caaac3a276de49faa2a85c /dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
parentAdded >=dev-util/codeblocks-1.0_pre20071215 to package.mask (diff)
downloadhistorical-7573f63b26125ac309d2d67070f33768f81451be.tar.gz
historical-7573f63b26125ac309d2d67070f33768f81451be.tar.bz2
historical-7573f63b26125ac309d2d67070f33768f81451be.zip
dev-util/codeblocks-1.0_pre20071215: version bump
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild b/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
new file mode 100644
index 000000000000..e8e63117c8e1
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild,v 1.1 2007/12/15 12:26:29 jurek Exp $
+
+inherit eutils autotools wxwidgets
+
+#needed for wxwidgets.eclass
+WX_GTK_VER="2.8"
+
+DESCRIPTION="Code::Blocks - a free cross-platform C/C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="unicode contrib debug"
+
+RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.5
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4
+ app-arch/zip"
+
+pkg_setup() {
+ if use unicode; then
+ #check for gtk2-unicode
+ need-wxwidgets unicode
+ else
+ #check for gtk2-ansi
+ need-wxwidgets gtk2
+ fi
+}
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+
+ local TMP
+
+ TMP="/usr/share/aclocal/libtool.m4"
+ einfo "Running ./bootstrap"
+ if [ -e "$TMP" ]; then
+ cp "$TMP" aclocal.m4 || die "cp failed"
+ fi
+ ./bootstrap || die "boostrap failed"
+
+ econf --with-wx-config="${WX_CONFIG}" \
+ $(use_enable contrib) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+}