summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-28 08:32:33 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-28 08:32:33 +0000
commit86e7bffc3ba3298ec0018b3af9397e68f1b2b473 (patch)
treef5288175fa8cba64821b1cfdf2b41d8eacd76d49 /dev-util/cppcheck/cppcheck-1.59-r1.ebuild
parentnet-misc/cbugzilla bump to 0.1.1 (diff)
downloadhistorical-86e7bffc3ba3298ec0018b3af9397e68f1b2b473.tar.gz
historical-86e7bffc3ba3298ec0018b3af9397e68f1b2b473.tar.bz2
historical-86e7bffc3ba3298ec0018b3af9397e68f1b2b473.zip
Drop old, migrate to python-r1 classes
Package-Manager: portage-2.2.0_alpha177/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'dev-util/cppcheck/cppcheck-1.59-r1.ebuild')
-rw-r--r--dev-util/cppcheck/cppcheck-1.59-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/cppcheck/cppcheck-1.59-r1.ebuild b/dev-util/cppcheck/cppcheck-1.59-r1.ebuild
new file mode 100644
index 000000000000..f84881ccf285
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.59-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.59-r1.ebuild,v 1.1 2013/05/28 08:32:23 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( ${PYTHON_DEPS} )
+ qt4? ( dev-qt/qtgui:4 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc readme.txt
+ if use qt4 ; then
+ dobin gui/${PN}-gui
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck}
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_install
+ popd
+ fi
+}