summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2003-11-15 18:29:18 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2003-11-15 18:29:18 +0000
commit67b8b5f8328415d2093e701c6791370d12a6234a (patch)
tree089c0bac3e9286d5c7328cb83a82d16f793ec5f1 /dev-util/cscope/cscope-15.4-r1.ebuild
parentFixed emacs lisp and site file installation. (diff)
downloadhistorical-67b8b5f8328415d2093e701c6791370d12a6234a.tar.gz
historical-67b8b5f8328415d2093e701c6791370d12a6234a.tar.bz2
historical-67b8b5f8328415d2093e701c6791370d12a6234a.zip
Fixed emacs lisp and site file installation.
Diffstat (limited to 'dev-util/cscope/cscope-15.4-r1.ebuild')
-rw-r--r--dev-util/cscope/cscope-15.4-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/cscope/cscope-15.4-r1.ebuild b/dev-util/cscope/cscope-15.4-r1.ebuild
new file mode 100644
index 000000000000..fe1f1fa72683
--- /dev/null
+++ b/dev-util/cscope/cscope-15.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.4-r1.ebuild,v 1.1 2003/11/15 18:29:15 jbms Exp $
+
+inherit gnuconfig elisp-common
+
+S=${WORKDIR}/${P}
+DESCRIPTION="CScope - interactively examine a C program"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+HOMEPAGE="http://cscope.sourceforge.net"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 -ppc -sparc -alpha -hppa -mips -arm"
+
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/flex
+ sys-devel/bison
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50xcscope-gentoo.el
+
+src_compile() {
+ gnuconfig_update
+
+ sed -i -e "s:={:{:" src/egrep.y
+
+ econf || die
+ make clean || die
+ emake || die
+
+ if use emacs
+ then
+ cd ${S}/contrib/xcscope
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc NEWS AUTHORS TODO COPYING ChangeLog INSTALL README*
+
+ if use emacs
+ then
+ cd ${S}/contrib/xcscope
+ elisp-install xcscope *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dobin cscope-indexer
+ fi
+ cp -r ${S}/contrib/webcscope ${D}/usr/share/doc/${P}/
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}