summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-03-20 17:54:42 +0000
committerLars Weiler <pylon@gentoo.org>2006-03-20 17:54:42 +0000
commita95a4ddafa80a218a475ddfcb659f44d49ad2bf4 (patch)
tree20737b104b53e461ad5f7a3a6caf101e2232ef28 /dev-util/cvs/cvs-1.12.12-r3.ebuild
parentStable on sparc wrt #126838 (diff)
downloadhistorical-a95a4ddafa80a218a475ddfcb659f44d49ad2bf4.tar.gz
historical-a95a4ddafa80a218a475ddfcb659f44d49ad2bf4.tar.bz2
historical-a95a4ddafa80a218a475ddfcb659f44d49ad2bf4.zip
Added support for gssapi as default with the kerberos-use-flag (thanks to exg for the hint) and build server support only when the server-use-flag is given.
Package-Manager: portage-2.1_pre6
Diffstat (limited to 'dev-util/cvs/cvs-1.12.12-r3.ebuild')
-rw-r--r--dev-util/cvs/cvs-1.12.12-r3.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-util/cvs/cvs-1.12.12-r3.ebuild b/dev-util/cvs/cvs-1.12.12-r3.ebuild
index 3fdd26435304..f391e7d6a7f5 100644
--- a/dev-util/cvs/cvs-1.12.12-r3.ebuild
+++ b/dev-util/cvs/cvs-1.12.12-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r3.ebuild,v 1.2 2006/03/01 19:50:11 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r3.ebuild,v 1.3 2006/03/20 17:54:42 pylon Exp $
inherit eutils pam
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="crypt doc emacs kerberos pam"
+IUSE="crypt doc emacs kerberos nls pam server"
DEPEND="virtual/libc
>=sys-libs/zlib-1.1.4
@@ -34,9 +34,11 @@ src_compile() {
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
- --disable-nls \
- `use_enable crypt encryption` \
- `use_enable pam` \
+ $(use_enable crypt encryption) \
+ $(use_with kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable server) \
|| die
emake || die "emake failed"
}