summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-07 23:53:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-07 23:53:29 +0000
commit72ed66ee25b72e506fdbfab509a8123a2cb1730c (patch)
tree14f1b26d196947e3c8dd6ad4d1966ce579ed41c2 /dev-util/dwdiff/dwdiff-1.8.ebuild
parentRevbump to fix documenation installation. New elog message wrt qt-assistant. ... (diff)
downloadhistorical-72ed66ee25b72e506fdbfab509a8123a2cb1730c.tar.gz
historical-72ed66ee25b72e506fdbfab509a8123a2cb1730c.tar.bz2
historical-72ed66ee25b72e506fdbfab509a8123a2cb1730c.zip
Initial commit.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-util/dwdiff/dwdiff-1.8.ebuild')
-rw-r--r--dev-util/dwdiff/dwdiff-1.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/dwdiff/dwdiff-1.8.ebuild b/dev-util/dwdiff/dwdiff-1.8.ebuild
new file mode 100644
index 000000000000..9de89e8012fa
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dwdiff/dwdiff-1.8.ebuild,v 1.1 2010/07/07 23:53:29 ssuominen Exp $
+
+EAPI=3
+inherit toolchain-funcs
+
+DESCRIPTION="A front-end for the diff program that operates at the word level instead of the line level"
+HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
+SRC_URI="http://os.ghalkes.nl/dist/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="dev-libs/icu"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/diffutils"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext) || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install || die
+ prepalldocs
+}