summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2004-12-16 14:32:52 +0000
committerChris Bainbridge <chrb@gentoo.org>2004-12-16 14:32:52 +0000
commitebc94d2522e0387b1cf3a35a944861308acb3961 (patch)
tree6078e2d6f453feab803eb74d8cea02cf9e971b1c /dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild
parentAdded image blending patch for ppc, possibly other big-endian arches. Fixes b... (diff)
downloadhistorical-ebc94d2522e0387b1cf3a35a944861308acb3961.tar.gz
historical-ebc94d2522e0387b1cf3a35a944861308acb3961.tar.bz2
historical-ebc94d2522e0387b1cf3a35a944861308acb3961.zip
New package
Diffstat (limited to 'dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild')
-rw-r--r--dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild b/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild
new file mode 100644
index 000000000000..975d497d5ae1
--- /dev/null
+++ b/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild,v 1.1 2004/12/16 14:32:52 chrb Exp $
+
+inherit eclipse-ext
+
+MY_PV=${PV//\./_}
+
+DESCRIPTION="Python Development Tools for Eclipse"
+HOMEPAGE="http://http://pydev.sourceforge.net"
+SRC_URI="mirror://sourceforge/pydev/pydev_${MY_PV}.zip"
+SLOT="1"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-util/eclipse-sdk-3.0
+ dev-lang/python"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+
+src_compile() {
+ einfo "${P} is a binary package"
+}
+
+src_install () {
+ eclipse-ext_require-slot 3 || die "Failed to find suitable Eclipse installation"
+
+ eclipse-ext_create-ext-layout binary || die "Failed to create layout"
+
+ eclipse-ext_install-features features/* || die "Failed to install features"
+ eclipse-ext_install-plugins plugins/* || die "Failed to install plugins"
+}