summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2005-08-14 20:54:40 +0000
committerMarius Mauch <genone@gentoo.org>2005-08-14 20:54:40 +0000
commit5c9bef87024ebcbd4481bb46222b4d83ee9641f8 (patch)
tree51144787689dd236daa981bf5ff88efcf5ad7f14 /dev-util/gambas/gambas-1.0.10.ebuild
parentAdd xorg-server-0.99.1-x86_64-1.patch to fix configure.ac on amd64. (diff)
downloadhistorical-5c9bef87024ebcbd4481bb46222b4d83ee9641f8.tar.gz
historical-5c9bef87024ebcbd4481bb46222b4d83ee9641f8.tar.bz2
historical-5c9bef87024ebcbd4481bb46222b4d83ee9641f8.zip
version bump+stabling
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'dev-util/gambas/gambas-1.0.10.ebuild')
-rw-r--r--dev-util/gambas/gambas-1.0.10.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/gambas/gambas-1.0.10.ebuild b/dev-util/gambas/gambas-1.0.10.ebuild
new file mode 100644
index 000000000000..14210fb46738
--- /dev/null
+++ b/dev-util/gambas/gambas-1.0.10.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.10.ebuild,v 1.1 2005/08/14 20:54:40 genone Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gambas/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -amd64"
+IUSE="postgres mysql sdl doc curl sqlite xml xsl zlib kde bzip2"
+
+RDEPEND="$(qt_min_version 3.2)
+ kde? ( >=kde-base/kdelibs-3.2 )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer sys-libs/gpm )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-misc/curl )
+ sqlite? ( dev-db/sqlite )
+ xml? ( dev-libs/libxml2 )
+ xsl? ( dev-libs/libxslt )
+ zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.59
+ >=sys-devel/automake-1.7.5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.6-configure-CFLAGS.patch
+
+ # replace braindead Makefile (it's getting better, but
+ # still has the stupid symlink stuff)
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-1.0_rc2" ./Makefile.am
+
+ aclocal && autoconf && automake || die "autotools failed"
+}
+
+src_compile() {
+ econf \
+ --enable-qt \
+ --enable-net \
+ --enable-vb \
+ $(use_enable mysql) \
+ $(use_enable postgres) \
+ $(use_enable sqlite) \
+ $(use_enable sdl) \
+ $(use_enable curl) \
+ $(use_enable zlib) \
+ $(use_enable xml libxml) \
+ $(use_enable xsl xslt) \
+ $(use_enable bzip2 bzlib2) \
+ $(use_enable kde) \
+ --disable-optimization \
+ --disable-debug \
+ --disable-profiling \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ make DESTDIR="${D}" install || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc ; then
+ mv "${D}"/usr/share/${PN}/help "${D}"/usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/${PN}/examples "${D}"/usr/share/doc/${PF}/examples
+ else
+ dohtml ${FILESDIR}/WebHome.html
+ fi
+ rm -r "${D}"/usr/share/${PN}/help "${D}"/usr/share/${PN}/examples
+ dosym ../doc/${PF}/html /usr/share/${PN}/help
+ dosym ../doc/${PF}/examples /usr/share/${PN}/examples
+}