summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 20:28:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 20:28:44 +0000
commita55c33e6c2487abcfeea95bf2c235e6f607d35a1 (patch)
tree6ba89d0ee2f46eae02a359681937df0db29b8bf4 /dev-util/gnustep-back/gnustep-back-0.8.3.ebuild
parentVersion bumped. (diff)
downloadhistorical-a55c33e6c2487abcfeea95bf2c235e6f607d35a1.tar.gz
historical-a55c33e6c2487abcfeea95bf2c235e6f607d35a1.tar.bz2
historical-a55c33e6c2487abcfeea95bf2c235e6f607d35a1.zip
whitespace cleanup
Diffstat (limited to 'dev-util/gnustep-back/gnustep-back-0.8.3.ebuild')
-rw-r--r--dev-util/gnustep-back/gnustep-back-0.8.3.ebuild38
1 files changed, 19 insertions, 19 deletions
diff --git a/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild b/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild
index 089563dac0b4..8e7c0e861548 100644
--- a/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild
+++ b/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild,v 1.8 2003/09/06 08:39:20 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild,v 1.9 2003/09/06 20:28:40 msterret Exp $
inherit base
@@ -11,8 +11,8 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 -ppc -sparc"
DEPEND="=dev-util/gnustep-gui-${PV}*
- >=media-libs/tiff-3.5.7
- >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2
x11-base/xfree
>=x11-wm/windowmaker-0.80.1"
S=${WORKDIR}/${P}
@@ -22,29 +22,29 @@ src_compile() {
. /usr/GNUstep/System/Makefiles/GNUstep.sh
./configure \
--prefix=/usr/GNUstep \
- --with-jpeg-library=/usr/lib \
- --with-jpeg-include=/usr/include \
- --with-tiff-library=/usr/lib \
- --with-tiff-include=/usr/include \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
--with-x || die "configure failed"
- # if we don't have Xft1, then we don't do Xft support at all
- # only gnustep-back > 0.8.4 has Xft2 support
- if [ ! -f "/usr/X11R6/include/X11/Xft1/Xft.h" ]; then
- sed "s,^#define HAVE_XFT.*,#undef HAVE_XFT,g" config.h > config.h.new
- sed "s,^#define HAVE_UTF8.*,#undef HAVE_UTF8,g" config.h.new > config.h
+ # if we don't have Xft1, then we don't do Xft support at all
+ # only gnustep-back > 0.8.4 has Xft2 support
+ if [ ! -f "/usr/X11R6/include/X11/Xft1/Xft.h" ]; then
+ sed "s,^#define HAVE_XFT.*,#undef HAVE_XFT,g" config.h > config.h.new
+ sed "s,^#define HAVE_UTF8.*,#undef HAVE_UTF8,g" config.h.new > config.h
- sed "s,^WITH_XFT=.*,WITH_XFT=no," config.make > config.make.new
- sed "s,-lXft,," config.make.new > config.make
- fi
+ sed "s,^WITH_XFT=.*,WITH_XFT=no," config.make > config.make.new
+ sed "s,-lXft,," config.make.new > config.make
+ fi
make || die
}
src_install () {
. /usr/GNUstep/System/Makefiles/GNUstep.sh
- make \
- GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
- INSTALL_ROOT_DIR=${D} \
- install || die "install failed"
+ make \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ install || die "install failed"
}