summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-08-24 16:52:47 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-08-24 16:52:47 +0000
commit3cee46bc7a7d45290bdc49e2f1aeb5daad96e71a (patch)
treec0aa083250635bd367f8b88a43a8fe50ae2adeb3 /dev-util/kscope/kscope-1.4.1.ebuild
parentppc stable, bug #144946 (diff)
downloadhistorical-3cee46bc7a7d45290bdc49e2f1aeb5daad96e71a.tar.gz
historical-3cee46bc7a7d45290bdc49e2f1aeb5daad96e71a.tar.bz2
historical-3cee46bc7a7d45290bdc49e2f1aeb5daad96e71a.zip
Version bump.
Package-Manager: portage-2.1.1_pre5-r3
Diffstat (limited to 'dev-util/kscope/kscope-1.4.1.ebuild')
-rw-r--r--dev-util/kscope/kscope-1.4.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/kscope/kscope-1.4.1.ebuild b/dev-util/kscope/kscope-1.4.1.ebuild
new file mode 100644
index 000000000000..c3d14ba5bfad
--- /dev/null
+++ b/dev-util/kscope/kscope-1.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kscope/kscope-1.4.1.ebuild,v 1.1 2006/08/24 16:52:47 carlo Exp $
+
+inherit kde
+
+DESCRIPTION="KScope is a KDE front-end to Cscope."
+HOMEPAGE="http://kscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="|| ( kde-base/kate kde-base/kdebase )"
+RDEPEND="${DEPEND}
+ media-gfx/graphviz
+ dev-util/ctags
+ >=dev-util/cscope-15.5-r4"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+need-kde 3.2
+
+src_install() {
+ kde_src_install
+
+ dodir /usr/share/applications/kde
+ mv ${D}/usr/share/applnk/Development/kscope.desktop \
+ ${D}/usr/share/applications/kde
+
+ insinto /usr/share/config
+ doins "${FILESDIR}/${PN}rc"
+}
+